summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort4ils2022-07-05 02:13:45 -0700
committert4ils2022-07-05 02:13:45 -0700
commit68bbe257ff562d57d9e14c29963993fb535771a9 (patch)
tree9f721a9192ac15b96f4d0491b40a2aaddea81be2
downloadaur-68bbe257ff562d57d9e14c29963993fb535771a9.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ea77f5b3eca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-pillow-avif-plugin
+ pkgdesc = A Python Pillow plugin that adds AVIF support via libavif
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/fdintino/pillow-avif-plugin
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ makedepends = python-pytest-runner
+ makedepends = libavif
+ depends = python
+ depends = python-pillow
+ options = !emptydirs
+ source = https://github.com/fdintino/pillow-avif-plugin/archive/refs/tags/v1.2.2.tar.gz
+ sha256sums = 935f24ecb2a9f6ffb5bbf43d6cebf53740d617bde3ed118be04e587aaf4e727e
+
+pkgname = python-pillow-avif-plugin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edd0e8a0d31d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: entriphy <t4ils.dev@gmail.com>
+
+pkgname=python-pillow-avif-plugin
+_pkgname=pillow-avif-plugin
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A Python Pillow plugin that adds AVIF support via libavif"
+arch=("any")
+url="https://github.com/fdintino/$_pkgname"
+license=("MIT")
+options=(!emptydirs)
+depends=("python" "python-pillow")
+makedepends=("python-build" "python-installer" "python-wheel" "python-setuptools" "python-pytest-runner" "libavif")
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=("935f24ecb2a9f6ffb5bbf43d6cebf53740d617bde3ed118be04e587aaf4e727e")
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}