summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDreamingRaven2019-06-25 10:46:22 +0100
committerDreamingRaven2019-06-25 10:46:22 +0100
commit68e17f71c0c60cc4a76a3d0de7745b207a077d3c (patch)
treed8946f65138bff550d1fbe48fc2730408f33b457
downloadaur-68e17f71c0c60cc4a76a3d0de7745b207a077d3c.tar.gz
Initial commit of PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD52
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4ab670e6443
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pimoroni-bme680-git
+ pkgdesc = Python library for the BME680 gas, temperature, humidity, and pressure sensor.
+ pkgver = v1.0.5.r14.91434ca
+ pkgrel = 1
+ url = https://github.com/DreamingRaven/bme680-python
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ source = bme680-python::git+https://github.com/pimoroni/bme680-python#branch=master
+ md5sums = SKIP
+
+pkgname = python-pimoroni-bme680-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29db71ad8b20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: George Raven <GeorgeRavenCommunity AT pm dot me>
+pkgname=python-pimoroni-bme680-git
+_pkgsrcname="bme680-python"
+
+pkgver=v1.0.5.r14.91434ca
+
+pkgrel=1
+pkgdesc="Python library for the BME680 gas, temperature, humidity, and pressure sensor."
+arch=('any')
+# pimoroni bme680 python source code url
+url="https://github.com/DreamingRaven/bme680-python"
+# set what branch you would like to pull from
+_branch="master"
+license=('MIT') # MIT is a special case store a copy in /usr/share/pkgname
+groups=()
+depends=("python")
+makedepends=("git") # 'bzr', 'git', 'mercurial' or 'subversion'
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("${_pkgsrcname}::git+https://github.com/pimoroni/${_pkgsrcname}#branch=${_branch}")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgsrcname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${_pkgsrcname}"
+ git checkout ${_branch} # get off of makepkg branch
+}
+
+build() {
+ cd "$srcdir/${_pkgsrcname}"
+}
+
+check() {
+ cd "$srcdir/${_pkgsrcname}"
+}
+
+package() {
+ cd "$srcdir/${_pkgsrcname}/library" # they store their setup.py here
+ python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ cd "$srcdir/${_pkgsrcname}" # returning to standard location
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}