summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-04-30 20:01:03 -0500
committerLuis Martinez2022-04-30 20:01:03 -0500
commit99b5418607b916e72344c3611ccad4895f33ffe9 (patch)
treef8ca39572956275e6d35014e9428231e0b4618f8
parent34b6b86d8d8c39dab0e51f1355f06617de2e3fe5 (diff)
downloadaur-99b5418607b916e72344c3611ccad4895f33ffe9.tar.gz
update to 0.6.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a684195f2895..9e3229e0605f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = python-pims
pkgdesc = Python Image Sequence: Load video and sequential images
- pkgver = 0.5
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/soft-matter/pims
arch = any
license = BSD
makedepends = python-setuptools
- depends = python-slicerator
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python>=3.7
+ depends = python-imageio
depends = python-numpy
- source = https://files.pythonhosted.org/packages/source/P/PIMS/PIMS-0.5.tar.gz
- sha256sums = a02cdcbb153e2792042fb0bae7df4f30878bbba1f2d176114a87ee0dc18715a0
+ depends = python-slicerator
+ source = python-pims-0.6.0.tar.gz::https://files.pythonhosted.org/packages/source/P/PIMS/PIMS-0.6.0.tar.gz
+ sha256sums = 1102742d642c8b8acc710d35d502b5d7085ee1288c3618373ef8c472030bc683
pkgname = python-pims
diff --git a/PKGBUILD b/PKGBUILD
index b1ce783f1f3d..1b2e54422c49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Francois Boulogne <fboulogne at april dot org>
pkgname=python-pims
_name="${pkgname#python-}"
-pkgver=0.5
+pkgver=0.6.0
pkgrel=1
pkgdesc="Python Image Sequence: Load video and sequential images"
url="https://github.com/soft-matter/pims"
arch=('any')
license=('BSD')
-depends=('python-slicerator' 'python-numpy')
+depends=('python>=3.7' 'python-imageio' 'python-numpy' 'python-slicerator')
# optdepends=('python-pillow: improved TIFF support'
# 'python-tifffile: alternative TIFF support')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
# checkdepends=('python-nose')
-source=("https://files.pythonhosted.org/packages/source/P/${_name^^}/${_name^^}-$pkgver.tar.gz")
-sha256sums=('a02cdcbb153e2792042fb0bae7df4f30878bbba1f2d176114a87ee0dc18715a0')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/P/${_name^^}/${_name^^}-$pkgver.tar.gz")
+sha256sums=('1102742d642c8b8acc710d35d502b5d7085ee1288c3618373ef8c472030bc683')
+
+prepare() {
+ cd "${_name^^}-$pkgver"
+ sed -i '/packages=/s/, "pims.tests"//' setup.py
+}
build() {
cd "${_name^^}-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
# check() {
@@ -30,7 +35,6 @@ build() {
package() {
cd "${_name^^}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}