summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2015-12-18 20:02:16 -0500
committerFrançois Boulogne2015-12-18 20:02:16 -0500
commite6c9693bc24ff2ed09078d0594e211fd8ebf90db (patch)
tree1496e2424131ab81bb257b2d24a032f5016a08bc
parentdb4e55cb12c0b6b7284d9a645b3545a7e3e826d7 (diff)
downloadaur-e6c9693bc24ff2ed09078d0594e211fd8ebf90db.tar.gz
v 0.3.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c14f2da24c1..5f4b108d54bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Dec 19 01:02:04 UTC 2015
pkgbase = python-pims
pkgdesc = Python Image Sequence: Load video and sequential images
- pkgver = 0.2.2
- pkgrel = 3
+ pkgver = 0.3.2
+ pkgrel = 1
url = https://github.com/soft-matter/pims
arch = any
license = BSD
@@ -11,9 +13,11 @@ pkgbase = python-pims
makedepends = python-matplotlib
makedepends = python-scikit-image
depends = python
- depends = python-tifffile
- source = https://github.com/soft-matter/pims/archive/v0.2.2.zip
- md5sums = 6d405418704cc063ea67629c26d4747e
+ depends = python-slicerator
+ optdepends = python-pillow: improved TIFF support
+ optdepends = python-tifffile: alternative TIFF support
+ source = https://github.com/soft-matter/pims/archive/v0.3.2.zip
+ md5sums = 3c6ed29354af5b1e1d64addf5e6b0c6d
pkgname = python-pims
diff --git a/PKGBUILD b/PKGBUILD
index c9e0394069fe..65ce3a54d242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: Francois Boulogne <fboulogne at april dot org>
pkgname=python-pims
-pkgver=0.2.2
-pkgrel=3
+pkgver=0.3.2
+pkgrel=1
pkgdesc="Python Image Sequence: Load video and sequential images"
url="https://github.com/soft-matter/pims"
arch=(any)
license=('BSD')
-depends=('python' 'python-tifffile')
+depends=('python' 'python-slicerator')
+optdepends=('python-pillow: improved TIFF support'
+ 'python-tifffile: alternative TIFF support')
makedepends=('python-setuptools' 'python-scipy' 'python-matplotlib' 'python-scikit-image')
checkdepends=('python-nose')
source=(https://github.com/soft-matter/pims/archive/v$pkgver.zip)
+# the fix will come with 0.3.3
#check() {
# cd $srcdir/pims-"$pkgver"
# nosetests3
@@ -20,4 +23,4 @@ package() {
cd $srcdir/pims-"$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}
-md5sums=('6d405418704cc063ea67629c26d4747e')
+md5sums=('3c6ed29354af5b1e1d64addf5e6b0c6d')