summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2021-11-09 22:47:56 +0100
committerClaudia Pellegrino2021-11-09 22:47:56 +0100
commit84f70b830da9d5d0555e5220ee0a0d7a1871a3e6 (patch)
tree67477b8e88698af21ae93a63d9e1b140f2b5e88a
downloadaur-84f70b830da9d5d0555e5220ee0a0d7a1871a3e6.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.editorconfig20
-rw-r--r--.gitattributes8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
5 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7646a11ed729
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-pip-audit-git
+ pkgdesc = A tool for scanning Python environments for known vulnerabilities
+ pkgver = r61.844c85f
+ pkgrel = 1
+ url = https://github.com/trailofbits/pip-audit
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-pip-api
+ depends = python-packaging
+ depends = python-dataclasses
+ depends = python-progress
+ depends = python-resolvelib
+ depends = python-html5lib
+ depends = python-cachecontrol
+ depends = python-lockfile
+ conflicts = python-pip-audit
+ options = !strip
+ source = pip-audit::git+https://github.com/trailofbits/pip-audit.git
+ sha512sums = SKIP
+
+pkgname = python-pip-audit-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..cf06dd3ed5ab
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[.gitattributes]
+indent_size = 16
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..7de6c048ded0
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,8 @@
+.editorconfig text eol=lf
+.gitattributes text eol=lf
+
+# LF required for interactive patching as of Git 2.17.1
+*.diff text eol=lf
+*.patch text eol=lf
+
+PKGBUILD text eol=lf
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..84500455d7d8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/.vscode
+/src
+/pip-audit
+/pkg
+*.pkg.*
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d99f6176c958
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+pkgname=python-pip-audit-git
+_gitpkgname=pip-audit
+pkgver=r61.844c85f
+pkgrel=1
+pkgdesc='A tool for scanning Python environments for known vulnerabilities'
+arch=('any')
+url='https://github.com/trailofbits/pip-audit'
+license=('Apache')
+depends=('python-pip-api' 'python-packaging' 'python-dataclasses' 'python-progress' 'python-resolvelib' 'python-html5lib' 'python-cachecontrol' 'python-lockfile')
+makedepends=('git' 'python-setuptools')
+conflicts=('python-pip-audit')
+options=('!strip')
+source=("${_gitpkgname}::git+https://github.com/trailofbits/pip-audit.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ printf "r%s.%s" \
+ "$(git -C "${_gitpkgname}" rev-list --count HEAD)" \
+ "$(git -C "${_gitpkgname}" rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_gitpkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_gitpkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}