summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2022-08-22 13:13:37 +0200
committerClaudia Pellegrino2022-08-22 13:13:37 +0200
commit8be89c6cd87bc929d937ac0c4b8ed61706c20d0b (patch)
tree0063850f06dcd51e5b39545f043f507408af849a
parentd6b7d273c35d75c3751aa07260c12da41927824a (diff)
downloadaur-8be89c6cd87bc929d937ac0c4b8ed61706c20d0b.tar.gz
Replace `flit` invocation with `build`
The `flit` command performs some up-front validation before it actually builds the package. This is intended for upstream project maintainers so they have a chance to learn about issues before they proceed to cut a release. Once a package is released, people who consume the package (which includes package repository maintainers) are assumed to be mainly interested in getting the already-released package to build. Therefore, they may simply want to run the build backend without caring about up-front validation. That’s what the `build` command does: invoke the suitable build backend, which in the case of `flit`, doesn’t run the validation steps. See discussion in [1]. [1]: https://github.com/pypa/flit/issues/580 CC: Thomas Kluyver <thomas@kluyver.me.uk> CC: William Woodruff <william@yossarian.net>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcd18964dc78..c07cec09f322 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pip-audit-git
pkgdesc = A tool for scanning Python environments for known vulnerabilities
pkgver = r280.0ea49c4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/trailofbits/pip-audit
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index c2a970cae78f..6472e715f7c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pip-audit-git
_gitpkgname=pip-audit
pkgver=r280.0ea49c4
-pkgrel=1
+pkgrel=2
pkgdesc='A tool for scanning Python environments for known vulnerabilities'
arch=('any')
url='https://github.com/trailofbits/pip-audit'
@@ -43,7 +43,7 @@ pkgver() {
build() {
cd "${srcdir}/${_gitpkgname}"
- python -m flit build --format wheel
+ python -m build --wheel --no-isolation
}
package() {