summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Baumann2018-03-10 20:05:56 +0100
committerAndreas Baumann2018-03-10 20:05:56 +0100
commit19451be3e91c1b101f5f672714595c0029a86aed (patch)
tree7aaa8333c08ffe3be3ed4d1aa6728ae4895e87d6
parent29479de2cc53006a449fa71ce59ca82a5ea81460 (diff)
downloadaur-python-pip-bootstrap.tar.gz
working
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
-rw-r--r--install.sh4
-rw-r--r--install2.sh4
4 files changed, 26 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e4572352ba6..d88edfcc66e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = python-pip-bootstrap
pkgver = 0.0.1
pkgrel = 1
url = https://bootstrap.pypa.io/
+ arch = i486
arch = i686
arch = x86_64
arch = armv6h
@@ -11,6 +12,10 @@ pkgbase = python-pip-bootstrap
sha512sums = 29971130c5d1d1baf2b51ef689b40c91fcd0d1e62de6f99d6abef6879684a59843be539cd112dfddc3637cc3d1a91c79f775d80f6aa2fe920252710d48d2934d
pkgname = python-pip-bootstrap
+ install = install.sh
+ depends = python
pkgname = python2-pip-bootstrap
+ install = install2.sh
+ depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index 7e741febaf9e..93c5d86e1b70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,23 @@ pkgname=('python-pip-bootstrap' 'python2-pip-bootstrap')
pkgver=0.0.1
pkgrel=1
pkgdesc="bootstap pip and setuptools for bootstrapping python"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=(i486 'i686' 'x86_64' 'armv6h' 'armv7h')
url="https://bootstrap.pypa.io/"
source=("https://bootstrap.pypa.io/get-pip.py")
sha512sums=('29971130c5d1d1baf2b51ef689b40c91fcd0d1e62de6f99d6abef6879684a59843be539cd112dfddc3637cc3d1a91c79f775d80f6aa2fe920252710d48d2934d')
-package_python-pip-bootstrap(){
- cd "${srcdir}"
- python get-pip.py
+package_python-pip-bootstrap() {
+ depends=('python')
+ install=install.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/."
}
-package_python2-pip-bootstrap(){
- cd "${srcdir}"
- python2 get-pip.py
+package_python2-pip-bootstrap() {
+ depends=('python2')
+ install=install2.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/get-pip2.py"
}
diff --git a/install.sh b/install.sh
new file mode 100644
index 000000000000..e81432e61f15
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python pip, setuptools and wheel.."
+ python /usr/bin/get-pip.py
+}
diff --git a/install2.sh b/install2.sh
new file mode 100644
index 000000000000..b6aa16fa635b
--- /dev/null
+++ b/install2.sh
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Bootstrapping python2 pip, setuptools and wheel.."
+ python2 /usr/bin/get-pip2.py
+}