summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2019-03-15 00:00:38 -0400
committerFlaviu Tamas2019-03-15 00:03:11 -0400
commit565d3dfb8eb2ce2830ac3e88ec16fe4238eabdd8 (patch)
treed07be4abd7251ec7a94236ee08e4653f414ea8eb
downloadaur-565d3dfb8eb2ce2830ac3e88ec16fe4238eabdd8.tar.gz
initial commit (based on repo package)
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch32
-rw-r--r--PKGBUILD54
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1df26e4dabcd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-pipenv-git
+ pkgdesc = Sacred Marriage of Pipfile, Pip, & Virtualenv.
+ pkgver = v2018.11.26.r218.gd5e446ee
+ pkgrel = 1
+ url = https://docs.pipenv.org
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ replaces = python-pipenv
+ source = python-pipenv::git+https://github.com/pypa/pipenv.git
+ source = 0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
+ sha256sums = SKIP
+ sha256sums = 50c9482911eb7d12bdce45b5e5a44efd4223d3d4a908c42b265d04ab58064e1f
+
+pkgname = python-pipenv-git
+ depends = python
+ depends = python-pip
+ depends = python-pew
+ depends = python-virtualenv
+ depends = python-setuptools
+ depends = python-virtualenv-clone
+ depends = python-certifi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..de78e9095a04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+/pkg
+/src
+*.gz
+python-pipenv/
diff --git a/0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch b/0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
new file mode 100644
index 000000000000..97eccc1caa1b
--- /dev/null
+++ b/0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
@@ -0,0 +1,32 @@
+From 29c76d50b90fd7b9494c61b0f028287580172940 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@archlinux.org>
+Date: Wed, 15 Aug 2018 22:37:12 -0400
+Subject: [PATCH] setup: don't setup_requires on things used to run development
+ tasks
+
+It's not actually needed for setup.py, and is only used for:
+- `invoke release.bump-version`
+- `invoke release.tag-version`
+
+Including it in setup_requires is just something which ends up being
+downloaded from PyPI as an egg, when doing possibly offline distro
+packaging.
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 7c87a2d6..179359f0 100644
+--- a/setup.py
++++ b/setup.py
+@@ -130,7 +130,6 @@ setup(
+ ],
+ },
+ python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
+- setup_requires=["invoke", "parver", ],
+ install_requires=required,
+ extras_require={
+ "test": ["pytest<4.0", "pytest-tap", "pytest-xdist", "flaky", "mock"],
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8804178aaa4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Flaviu Tamas <me@flaviutamas.com>
+# Contributor: Morten Linderud <foxboron@archlinux.org>
+# Contributor: Maikel Wever <maikelwever@gmail.com>
+
+_pkgname=python-pipenv
+pkgname=$_pkgname-git
+pkgver=v2018.11.26.r218.gd5e446ee
+pkgrel=1
+pkgdesc="Sacred Marriage of Pipfile, Pip, & Virtualenv."
+url="https://docs.pipenv.org"
+arch=('any')
+license=('MIT')
+makedepends=('python-setuptools')
+conflicts=($_pkgname)
+provides=($_pkgname)
+#checkdepends=('python-pytest' 'python-pytest-runner'
+# 'python-pip' 'python-certifi' 'python-virtualenv'
+# 'python-virtualenv-clone' 'python-strict-rfc3339'
+# 'python-pytz' 'python-flaky' 'python-mock')
+source=("${_pkgname}::git+https://github.com/pypa/pipenv.git"
+ "0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch")
+sha256sums=('SKIP'
+ '50c9482911eb7d12bdce45b5e5a44efd4223d3d4a908c42b265d04ab58064e1f')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ patch -p1 -d "$srcdir/$_pkgname" < 0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
+}
+
+build(){
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+#check(){
+# cd "$srcdir/pipenv-$pkgver"
+# python setup.py pytest
+#}
+
+package() {
+ depends=('python' 'python-pip' 'python-pew' 'python-virtualenv'
+ 'python-setuptools' 'python-virtualenv-clone' 'python-certifi')
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ PIPENV_SHELL=bash python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/pipenv"
+ PIPENV_SHELL=zsh python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_pipenv"
+ PIPENV_SHELL=fish python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/fish/vendor_completions.d/pipenv.fish"
+}