summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2019-07-29 18:59:21 -0400
committerFlaviu Tamas2019-07-29 18:59:21 -0400
commit6078d1a63092e3f90eb02949ffa01aee28e2b30b (patch)
tree3ebd486f95201a3977bce1f0c74eb07e6bd8e85c
parent565d3dfb8eb2ce2830ac3e88ec16fe4238eabdd8 (diff)
downloadaur-6078d1a63092e3f90eb02949ffa01aee28e2b30b.tar.gz
Fix build with latest pipenv
-rw-r--r--.SRCINFO9
-rw-r--r--0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch32
-rw-r--r--PKGBUILD14
3 files changed, 8 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1df26e4dabcd..500de0075eda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-pipenv-git
pkgdesc = Sacred Marriage of Pipfile, Pip, & Virtualenv.
- pkgver = v2018.11.26.r218.gd5e446ee
- pkgrel = 1
+ pkgver = v2018.11.26.r612.gf4b66a77
+ pkgrel = 2
url = https://docs.pipenv.org
arch = any
license = MIT
makedepends = python-setuptools
- replaces = python-pipenv
+ provides = python-pipenv
+ conflicts = python-pipenv
source = python-pipenv::git+https://github.com/pypa/pipenv.git
- source = 0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
sha256sums = SKIP
- sha256sums = 50c9482911eb7d12bdce45b5e5a44efd4223d3d4a908c42b265d04ab58064e1f
pkgname = python-pipenv-git
depends = python
diff --git a/0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch b/0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
deleted file mode 100644
index 97eccc1caa1b..000000000000
--- a/0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 29c76d50b90fd7b9494c61b0f028287580172940 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Wed, 15 Aug 2018 22:37:12 -0400
-Subject: [PATCH] setup: don't setup_requires on things used to run development
- tasks
-
-It's not actually needed for setup.py, and is only used for:
-- `invoke release.bump-version`
-- `invoke release.tag-version`
-
-Including it in setup_requires is just something which ends up being
-downloaded from PyPI as an egg, when doing possibly offline distro
-packaging.
----
- setup.py | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 7c87a2d6..179359f0 100644
---- a/setup.py
-+++ b/setup.py
-@@ -130,7 +130,6 @@ setup(
- ],
- },
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
-- setup_requires=["invoke", "parver", ],
- install_requires=required,
- extras_require={
- "test": ["pytest<4.0", "pytest-tap", "pytest-xdist", "flaky", "mock"],
---
-2.18.0
-
diff --git a/PKGBUILD b/PKGBUILD
index c8804178aaa4..f1e31a3edb2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname=python-pipenv
pkgname=$_pkgname-git
-pkgver=v2018.11.26.r218.gd5e446ee
-pkgrel=1
+pkgver=v2018.11.26.r612.gf4b66a77
+pkgrel=2
pkgdesc="Sacred Marriage of Pipfile, Pip, & Virtualenv."
url="https://docs.pipenv.org"
arch=('any')
@@ -17,20 +17,14 @@ provides=($_pkgname)
# 'python-pip' 'python-certifi' 'python-virtualenv'
# 'python-virtualenv-clone' 'python-strict-rfc3339'
# 'python-pytz' 'python-flaky' 'python-mock')
-source=("${_pkgname}::git+https://github.com/pypa/pipenv.git"
- "0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch")
-sha256sums=('SKIP'
- '50c9482911eb7d12bdce45b5e5a44efd4223d3d4a908c42b265d04ab58064e1f')
+source=("${_pkgname}::git+https://github.com/pypa/pipenv.git")
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- patch -p1 -d "$srcdir/$_pkgname" < 0001-setup-don-t-setup_requires-on-things-used-to-run-dev.patch
-}
-
build(){
cd "$srcdir/$_pkgname"
python setup.py build