summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlaï Deutel2022-03-07 22:40:38 -0500
committerIlaï Deutel2022-03-07 22:40:38 -0500
commitc3092b1bff8368024af529a1092ff36418bff34e (patch)
treee0fca420a0bb4dcb5edadfff44490724750b38ac
parent46b1d5201cce87958068af9a99a6d5b49c5a37b9 (diff)
downloadaur-c3092b1bff8368024af529a1092ff36418bff34e.tar.gz
upgpkg: python-pipenv-git 2022.1.8.r59.g8753ceea-1
Co-authored-by: Further <55025025+ifurther@users.noreply.github.com>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 184306bd7154..487c9d4b34af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pipenv-git
pkgdesc = Python Development Workflow for Humans.
- pkgver = 2018.11.26.r751.g5c01c682
+ pkgver = 2022.1.8.r59.g8753ceea
pkgrel = 1
url = https://pipenv.pypa.io
arch = any
@@ -18,4 +18,3 @@ pkgbase = python-pipenv-git
sha256sums = SKIP
pkgname = python-pipenv-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 88bdc071790c..8a8216134a1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Ilaï Deutel <PlMWPh1WSmypRv0JQljz> (echo ... | tr 'A-Za-z' 'l-za-kL-ZA-K' | base64 -d)
+# Contributor: i.further
# Contributor: Flaviu Tamas <me@flaviutamas.com>
# Contributor: Morten Linderud <foxboron@archlinux.org>
# Contributor: Maikel Wever <maikelwever@gmail.com>
pkgname=python-pipenv-git
-pkgver=2018.11.26.r751.g5c01c682
+pkgver=2022.1.8.r59.g8753ceea
pkgrel=1
pkgdesc="Python Development Workflow for Humans."
url="https://pipenv.pypa.io"
@@ -65,9 +66,9 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- PIPENV_SHELL=bash python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/pipenv"
- PIPENV_SHELL=zsh python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_pipenv"
- PIPENV_SHELL=fish python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/fish/vendor_completions.d/pipenv.fish"
+ _PIPENV_COMPLETE=bash_source python -m pipenv | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/pipenv"
+ _PIPENV_COMPLETE=zsh_source python -m pipenv | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_pipenv"
+ /usr/bin/env _PIPENV_COMPLETE=fish_source python -m pipenv | install -Dm644 /dev/stdin "${pkgdir}/usr/share/fish/vendor_completions.d/pipenv.fish"
cd pipenv/vendor
find -name '*LICENSE' -type f -exec install -Dm 644 {} "${pkgdir}/usr/share/licenses/${pkgname}/vendor/{}" \;