summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlaï Deutel2019-10-07 21:39:23 -0700
committerIlaï Deutel2019-10-07 21:47:13 -0700
commitf1d0d2cdcd47b505cdee12025dceb9aeed3ce1a0 (patch)
tree2ef2fcd8f151ea8d980a36dafc1a5e68543102de
parent6078d1a63092e3f90eb02949ffa01aee28e2b30b (diff)
downloadaur-f1d0d2cdcd47b505cdee12025dceb9aeed3ce1a0.tar.gz
Fix pkg_resources.extern bug; check(); upgpkg: python-pipenv-git 2018.11.26.r641.g02fc6396-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD89
2 files changed, 73 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 500de0075eda..20f0896eee19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = python-pipenv-git
- pkgdesc = Sacred Marriage of Pipfile, Pip, & Virtualenv.
- pkgver = v2018.11.26.r612.gf4b66a77
- pkgrel = 2
- url = https://docs.pipenv.org
+ pkgdesc = Python Development Workflow for Humans.
+ pkgver = 2018.11.26.r641.g02fc6396
+ pkgrel = 1
+ url = https://pipenv.readthedocs.io
arch = any
license = MIT
- makedepends = python-setuptools
- provides = python-pipenv
- conflicts = python-pipenv
- source = python-pipenv::git+https://github.com/pypa/pipenv.git
- sha256sums = SKIP
-
-pkgname = python-pipenv-git
+ makedepends = git
depends = python
depends = python-pip
- depends = python-pew
depends = python-virtualenv
depends = python-setuptools
depends = python-virtualenv-clone
depends = python-certifi
+ provides = python-pipenv
+ conflicts = python-pipenv
+ source = python-pipenv-git::git+https://github.com/pypa/pipenv.git
+ sha256sums = SKIP
+
+pkgname = python-pipenv-git
diff --git a/PKGBUILD b/PKGBUILD
index f1e31a3edb2f..94f1fc6f27e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,81 @@
-# Maintainer: Flaviu Tamas <me@flaviutamas.com>
+# Maintainer: Ilaï Deutel
+# Contributor: Flaviu Tamas <me@flaviutamas.com>
# Contributor: Morten Linderud <foxboron@archlinux.org>
# Contributor: Maikel Wever <maikelwever@gmail.com>
-_pkgname=python-pipenv
-pkgname=$_pkgname-git
-pkgver=v2018.11.26.r612.gf4b66a77
-pkgrel=2
-pkgdesc="Sacred Marriage of Pipfile, Pip, & Virtualenv."
-url="https://docs.pipenv.org"
+pkgname=python-pipenv-git
+pkgver=2018.11.26.r641.g02fc6396
+pkgrel=1
+pkgdesc="Python Development Workflow for Humans."
+url="https://pipenv.readthedocs.io"
arch=('any')
license=('MIT')
-makedepends=('python-setuptools')
-conflicts=($_pkgname)
-provides=($_pkgname)
-#checkdepends=('python-pytest' 'python-pytest-runner'
-# 'python-pip' 'python-certifi' 'python-virtualenv'
-# 'python-virtualenv-clone' 'python-strict-rfc3339'
-# 'python-pytz' 'python-flaky' 'python-mock')
-source=("${_pkgname}::git+https://github.com/pypa/pipenv.git")
+depends=('python' 'python-pip' 'python-virtualenv' 'python-setuptools'
+ 'python-virtualenv-clone' 'python-certifi')
+makedepends=('git')
+conflicts=('python-pipenv')
+provides=('python-pipenv')
+# checkdepends=('python-pytest' 'python-pytest-xdist' 'python-flaky' 'python-mock')
+source=(
+ "$pkgname::git+https://github.com/pypa/pipenv.git"
+ # The following sources are used for check()
+ # "test-submodules/dateutil::git+https://github.com/dateutil/dateutil.git"
+ # "test-submodules/flask::git+https://github.com/pallets/flask.git"
+ # "test-submodules/jinja2::git+https://github.com/pallets/jinja.git"
+ # "test-submodules/pinax::git+https://github.com/pinax/pinax.git"
+ # "test-submodules/pyinstaller::git+https://github.com/pyinstaller/pyinstaller.git"
+ # "test-submodules/pypi::git+https://github.com/sarugaku/pipenv-test-artifacts.git"
+ # "test-submodules/requests::git+https://github.com/psf/requests.git"
+ # "test-submodules/six::git+https://github.com/benjaminp/six.git"
+)
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build(){
- cd "$srcdir/$_pkgname"
+prepare() {
+ # The setuptools package removes pkg_resources.extern because "Upstream
+ # devendoring logic is badly broken". We use the canonical location instead.
+ # Relevant links:
+ # https://bugs.archlinux.org/task/58670
+ # https://github.com/pypa/pip/issues/5429
+ # https://github.com/pypa/setuptools/issues/1383
+ # https://github.com/sarugaku/requirementslib/issues/185
+ find "$srcdir/$pkgname/pipenv/vendor/requirementslib" -name \*.py \
+ -exec sed -i 's/pkg_resources.extern.packaging/packaging/' {} \;
+}
+
+build() {
+ cd "$srcdir/$pkgname"
python setup.py build
}
-#check(){
-# cd "$srcdir/pipenv-$pkgver"
-# python setup.py pytest
-#}
+# check(){
+# cd "$srcdir/$pkgname/tests"
+#
+# git submodule init pypi
+# git config submodule.tests/pypi.url "$srcdir/pypi"
+#
+# for artifact in dateutil flask jinja2 pinax pyinstaller requests requests-2.18.4 six six-1.9.0; do
+# git submodule init "test_artifacts/git/$artifact"
+# git config "submodule.tests/test_artifacts/git/$artifact.url" "$srcdir/${artifact%-*}"
+# done
+#
+# git submodule update
+#
+# python -m venv --system-site-packages --without-pip env
+# env/bin/python ../setup.py install --skip-build
+# (cd pytest-pypi; ../env/bin/python setup.py develop)
+#
+# env/bin/python -m pytest -k 'not needs_internet and not system'
+# }
package() {
- depends=('python' 'python-pip' 'python-pew' 'python-virtualenv'
- 'python-setuptools' 'python-virtualenv-clone' 'python-certifi')
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$pkgname"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
PIPENV_SHELL=bash python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/pipenv"
PIPENV_SHELL=zsh python -m pipenv --completion | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_pipenv"