summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 21:22:51 -0700
committerGI_Jack2023-05-13 21:22:51 -0700
commitef0ab49af62ab65d17af8ee80d41ae033e2ee0ce (patch)
treef5a5668c733e6a25c072fa6abefd4f953f07bffc
parent72d6da9c02b23ed0a3b52a06a15d5701841afc4d (diff)
downloadaur-ef0ab49af62ab65d17af8ee80d41ae033e2ee0ce.tar.gz
version 5.2.3
updated for modern packaging guidelines
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8698ff549e0..b5b575746ad5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
# Generated by mksrcinfo(replacement shim) v8
-# Thu Jan 21 08:05:33 PM EST 2021
+# Sat May 13 09:22:47 PM PDT 2023
pkgbase = python-piplapis
pkgdesc = Python Library for interfacing with pipl.com
- pkgver = 5.2.2
+ pkgver = 5.2.3
pkgrel = 1
url = https://pypi.org/project/piplapis-python/
arch = any
license = Apache2
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-six
- makedepends = python-setuptools
depends = python-pytz
- source = https://files.pythonhosted.org/packages/source/p/piplapis-python/piplapis-python-5.2.2.tar.gz
- sha256sums = c511498cd30be09e721e287c8d59ea956f7b97febc3d290cb53574c7b16c5968
+ source = https://files.pythonhosted.org/packages/source/p/piplapis-python/piplapis-python-5.2.3.tar.gz
+ sha256sums = 53effde6eb0e59401332f9f4a3a54666990782a50cde9d3f8f4d46d111f69f33
pkgname = python-piplapis
-
diff --git a/PKGBUILD b/PKGBUILD
index 2da74c4997be..ef6bdd5caa63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
pkgname=python-piplapis
_pkgname=piplapis-python
-pkgver=5.2.2
+pkgver=5.2.3
pkgrel=1
pkgdesc="Python Library for interfacing with pipl.com"
url="https://pypi.org/project/piplapis-python/"
arch=('any')
license=('Apache2')
depends=('python-pytz')
-makedepends=('python-six' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-six')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('c511498cd30be09e721e287c8d59ea956f7b97febc3d290cb53574c7b16c5968')
+sha256sums=('53effde6eb0e59401332f9f4a3a54666990782a50cde9d3f8f4d46d111f69f33')
-package() {
- cd piplapis-python-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+build() {
+ cd "piplapis-python-${pkgver}"
+ python -m build --wheel --no-isolation
}
+package() {
+ cd "piplapis-python-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}