summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeifeng Yu2018-02-06 14:50:14 -0500
committerPeifeng Yu2018-02-06 14:50:14 -0500
commit3a960d964197d1a047c282fb91646c6a7961ca9e (patch)
tree0b51e932b7a86af0651dfc903aeb96e662bac8a5
downloadaur-3a960d964197d1a047c282fb91646c6a7961ca9e.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD25
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e81108f77e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pipsi
+ pkgdesc = Wraps pip and virtualenv to install scripts
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/mitsuhiko/pipsi/
+ arch = any
+ license = BSD
+ depends = python-virtualenv
+ depends = python-click
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/p/pipsi/pipsi-0.9.tar.gz
+ sha256sums = 688b688cc8a7a76612c0d4d1839aaef98ece8382d4382b9d8b6f0caa65f0ed34
+
+pkgname = python-pipsi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8db5aa808c80
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+# Ignore downloaded source files
+*.tar.gz
+*.tar.xz
+*.tgz
+
+# Ignore packages
+*.pkg.tar.xz
+
+# Ignore log files
+*.log
+
+# Ignore all subdirs
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b752878a5460
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Aetf <aetf at unlimitedcodeworks dot xyz>
+# Contributor: Thomas Weißschuh <thomas t-8ch de>
+
+pkgname=python-pipsi
+_name=pipsi
+pkgver=0.9
+pkgrel=1
+pkgdesc='Wraps pip and virtualenv to install scripts'
+arch=('any')
+url='https://github.com/mitsuhiko/pipsi/'
+license=('BSD')
+depends=(python-virtualenv python-click python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+sha256sums=('688b688cc8a7a76612c0d4d1839aaef98ece8382d4382b9d8b6f0caa65f0ed34')