summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu, Zhenyu2024-04-09 14:17:53 +0800
committerWu, Zhenyu2024-04-09 14:17:53 +0800
commit502fdb2fd3ebb1d44ea6796933656057cdf8c559 (patch)
treef9f39d3862d4108c06fc6355126512a730889cbe
downloadaur-502fdb2fd3ebb1d44ea6796933656057cdf8c559.tar.gz
:tada: Initial
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6621dae9d5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-plants-vs-zombies
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/marblexu/PythonPlantsVsZombies
+ arch = any
+ license = MIT
+ makedepends = python-installer
+ depends = python-pygame
+ source = https://files.pythonhosted.org/packages/py3/p/plants_vs_zombies/plants_vs_zombies-0.0.1-py3-none-any.whl
+ sha256sums = 8bfae4d34c040c8640ef773bca172d28c6b9605f4da4561fd2afe91c37244fc5
+
+pkgname = python-plants-vs-zombies
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4b62e7679d6f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
+!/nvchecker.toml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fe27124ae5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+_pkgname=plants-vs-zombies
+pkgname=python-$_pkgname
+pkgver=0.0.1
+pkgrel=1
+pkgdesc=""
+arch=(any)
+url=https://github.com/marblexu/PythonPlantsVsZombies
+depends=(python-pygame)
+makedepends=(python-installer)
+license=(MIT)
+_py=py3
+source=("https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/${_pkgname//-/_}/${_pkgname//-/_}-$pkgver-$_py-none-any.whl")
+sha256sums=('8bfae4d34c040c8640ef773bca172d28c6b9605f4da4561fd2afe91c37244fc5')
+
+package() {
+ python -minstaller -d"$pkgdir" ./*.whl
+}