summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2022-10-30 13:50:42 -0700
committermutantmonkey2022-10-30 13:50:42 -0700
commit42d8b19211b2ff25d6fda5894846b855ca76cdcd (patch)
tree9ba40aca9a0c33d8af9bca49941f4b52e2f0931e
parent9d68ea3eec76c24f05693046a677531131239025 (diff)
downloadaur-42d8b19211b2ff25d6fda5894846b855ca76cdcd.tar.gz
upgpkg: python-plexapi 4.13.0-1
Upgrade to 4.13.0 and switch to the current PEP 517 packaging guidelines.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2d1ac8c668a..0b08f68e3f5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-plexapi
pkgdesc = Python bindings for the Plex API.
- pkgver = 4.12.0
+ pkgver = 4.13.0
pkgrel = 1
url = https://github.com/pkkid/python-plexapi
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-requests
depends = python-tqdm
depends = python-websocket-client
- source = https://files.pythonhosted.org/packages/source/P/PlexAPI/PlexAPI-4.12.0.tar.gz
- sha256sums = 6c98019ce2e4c81db6be7dde025f929830c83544ee491bb680c30f588f43942a
+ source = https://files.pythonhosted.org/packages/source/P/PlexAPI/PlexAPI-4.13.0.tar.gz
+ sha256sums = 86e92cdb2fa6f38f7c518ef42144cd5276a69b083d0df95e9a9fede881e1fa83
pkgname = python-plexapi
diff --git a/PKGBUILD b/PKGBUILD
index afd670c36443..ee4ead50a4a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,23 @@
pkgname=python-plexapi
_name="PlexAPI"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/pkkid/python-plexapi/archive/$pkgver.tar.gz")
-pkgver=4.12.0
+pkgver=4.13.0
pkgrel=1
pkgdesc="Python bindings for the Plex API."
arch=('any')
url="https://github.com/pkkid/python-plexapi"
license=('BSD')
-depends=('python-requests'
- 'python-tqdm'
- 'python-websocket-client')
-makedepends=()
+depends=('python-requests' 'python-tqdm' 'python-websocket-client')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('6c98019ce2e4c81db6be7dde025f929830c83544ee491bb680c30f588f43942a')
+sha256sums=('86e92cdb2fa6f38f7c518ef42144cd5276a69b083d0df95e9a9fede881e1fa83')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$_name-$pkgver"
- python ./setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}