summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitrios Vogiatzis2018-03-03 10:42:05 -0500
committerDimitrios Vogiatzis2018-03-03 10:42:05 -0500
commit6646aacb4adc1f4c909c8fe0c27ed71b8bdd53aa (patch)
treeb9c46eb4be37508ca0589d6d4d49f9313f7ed754
downloadaur-6646aacb4adc1f4c909c8fe0c27ed71b8bdd53aa.tar.gz
Initial commit.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9276576603ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-plexapi
+ pkgdesc = Python bindings for the Plex API.
+ pkgver = 3.0.6
+ pkgrel = 1
+ url = https://github.com/pkkid/python-plexapi
+ arch = any
+ license = BSD
+ source = python-plexapi::git://github.com/pkkid/python-plexapi.git#tag=3.0.6
+ md5sums = SKIP
+
+pkgname = python-plexapi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c048e1a4a133
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Dimitrios Vogiatzis <me@dimtree.net>
+
+pkgname=python-plexapi
+pkgver=3.0.6
+pkgrel=1
+pkgdesc="Python bindings for the Plex API."
+arch=('any')
+url="https://github.com/pkkid/python-plexapi"
+license=('BSD')
+depends=()
+makedepends=()
+source=("$pkgname"::"git://github.com/pkkid/python-plexapi.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname"
+ python ./setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}