summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2019-09-29 15:27:42 -0400
committerKyle Sferrazza2019-09-29 15:32:07 -0400
commit6de4a8a947c16f32a28162b1a75d406a776056c4 (patch)
tree16af7c08447a04f3e6a889cbfa19e790f7b0c0f4
parentf1d110ab14b25d5a2bbce4ffcfffad11e367e8d8 (diff)
downloadaur-6de4a8a947c16f32a28162b1a75d406a776056c4.tar.gz
v3.1.0 from PyPI
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD14
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d4a08d12830..cf14a091d85c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-plexapi
pkgdesc = Python bindings for the Plex API.
- pkgver = 3.0.6
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/pkkid/python-plexapi
arch = any
@@ -8,8 +8,8 @@ pkgbase = python-plexapi
depends = python-requests
depends = python-tqdm
depends = python-websocket-client
- source = python-plexapi-3.0.6.tar.gz::https://github.com/pkkid/python-plexapi/archive/3.0.6.tar.gz
- sha256sums = d43947afb640d47a12525fea24c9d9e1afc80e7fbc7991666184bd942dae130d
+ source = https://files.pythonhosted.org/packages/source/P/PlexAPI/PlexAPI-3.1.0.tar.gz
+ sha256sums = 4044876f354b6b93737f704e41910c5a5537e000ad9d4dc79b4ded7bc9e9ce4d
pkgname = python-plexapi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d490a56582c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
index 6134afc4be49..6daa600fed93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
-# Maintainer: Dimitrios Vogiatzis <me@dimtree.net>
+# Maintainer: Kyle Sferrazza <kyle.sferrazza@gmail.com>
+# Contributor: Dimitrios Vogiatzis <me@dimtree.net>
pkgname=python-plexapi
-pkgver=3.0.6
+_name="PlexAPI"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/pkkid/python-plexapi/archive/$pkgver.tar.gz")
+pkgver=3.1.0
pkgrel=1
pkgdesc="Python bindings for the Plex API."
arch=('any')
@@ -11,11 +14,10 @@ depends=('python-requests'
'python-tqdm'
'python-websocket-client')
makedepends=()
-source=("$pkgname-$pkgver.tar.gz::https://github.com/pkkid/python-plexapi/archive/$pkgver.tar.gz")
-sha256sums=('d43947afb640d47a12525fea24c9d9e1afc80e7fbc7991666184bd942dae130d')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('4044876f354b6b93737f704e41910c5a5537e000ad9d4dc79b4ded7bc9e9ce4d')
package() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
python ./setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}