summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2023-01-13 13:35:21 +0000
committerGreyson Christoforo2023-01-13 13:35:21 +0000
commit032a38db2f8cbe069f1953d30ec95491a375d3be (patch)
tree5efec38e528b7267cbedf0539406e4eb934357d3
parent22623b44249b5158101e04bdd734113ac9e744b0 (diff)
downloadaur-032a38db2f8cbe069f1953d30ec95491a375d3be.tar.gz
fix architecture, add core tests, update optdeps
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD45
2 files changed, 40 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9edbfd323ea..b44f8622020f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,8 +3,10 @@ pkgbase = python-plotly
pkgver = 5.12.0
pkgrel = 2
url = https://github.com/plotly/plotly.py
- arch = any
+ arch = x86_64
license = MIT
+ checkdepends = python-requests
+ checkdepends = python-pytest
makedepends = python-setuptools
makedepends = python-jupyter_core
makedepends = python-tornado
@@ -19,6 +21,11 @@ pkgbase = python-plotly
optdepends = python-matplotlib
optdepends = python-pillow
optdepends = python-scipy
+ optdepends = python-ipykernel
+ optdepends = python-pandas
+ optdepends = python-colorcet
+ optdepends = python-inflect
+ optdepends = python-psutil
options = !strip
source = python-plotly-5.12.0.tar.gz::https://github.com/plotly/plotly.py/archive/v5.12.0.tar.gz
sha256sums = 33548f8abc3310acde8ba7d74a57a652ed278ef5c4a999a61ae9fb45cb1961e4
diff --git a/PKGBUILD b/PKGBUILD
index 7e23f742242d..b04fc30c80d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,39 @@ pkgname=python-plotly
pkgver=5.12.0
pkgrel=2
pkgdesc="An open-source, interactive graphing library"
+arch=('x86_64')
url="https://github.com/plotly/plotly.py"
-depends=(python
-python-tenacity)
+license=('MIT')
+depends=(
+python
+python-tenacity
+)
# optdepends based on optional_requirements.txt
optdepends=(
-'ipython'
-'jupyterlab'
-'python-ipywidgets'
-'python-numpy'
-'python-matplotlib'
-'python-pillow'
-'python-scipy')
-makedepends=(python-setuptools
+ipython
+jupyterlab
+python-ipywidgets
+python-numpy
+python-matplotlib
+python-pillow
+python-scipy
+python-ipykernel
+python-pandas
+python-colorcet
+python-inflect
+python-psutil
+)
+makedepends=(
+python-setuptools
python-jupyter_core
python-tornado
jupyterlab
-npm)
-license=('MIT')
-arch=('any')
+npm
+)
+checkdepends=(
+python-requests
+python-pytest
+)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/plotly/plotly.py/archive/v${pkgver}.tar.gz")
options=(!strip) # strip isn't useful for python files and takes forever
sha256sums=('33548f8abc3310acde8ba7d74a57a652ed278ef5c4a999a61ae9fb45cb1961e4')
@@ -33,6 +47,11 @@ build() {
NODE_OPTIONS=--openssl-legacy-provider python setup.py build
}
+check() {
+ cd plotly.py-${pkgver}/packages/python/plotly
+ pytest plotly/tests/test_core
+}
+
package() {
cd plotly.py-${pkgver}/packages/python/plotly
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build