summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2023-01-13 18:39:03 +0000
committerGreyson Christoforo2023-01-13 18:39:03 +0000
commit95cd6fc02061e4d2191d44089cc8baeb482f7e98 (patch)
treed0078651f41409fb2ad8953fa33d8ad55d7b344b
parentb76f4c52af2c5bb2bf147411f64ead1d19d1273f (diff)
downloadaur-95cd6fc02061e4d2191d44089cc8baeb482f7e98.tar.gz
remove npm stuff and move etc/
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 382a96e8e5c0..27a27ff39a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-plotly
pkgdesc = An open-source, interactive graphing library
pkgver = 5.12.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/plotly/plotly.py
arch = x86_64
license = MIT
@@ -11,7 +11,6 @@ pkgbase = python-plotly
makedepends = python-jupyter_core
makedepends = python-tornado
makedepends = jupyterlab
- makedepends = npm
depends = python
depends = python-tenacity
optdepends = ipython
diff --git a/PKGBUILD b/PKGBUILD
index 1daab4c0df88..956712d875cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-plotly
pkgver=5.12.0
-pkgrel=3
+pkgrel=4
pkgdesc="An open-source, interactive graphing library"
arch=('x86_64')
url="https://github.com/plotly/plotly.py"
@@ -32,7 +32,6 @@ python-setuptools
python-jupyter_core
python-tornado
jupyterlab
-npm
)
checkdepends=(
python-requests
@@ -44,7 +43,7 @@ sha256sums=('33548f8abc3310acde8ba7d74a57a652ed278ef5c4a999a61ae9fb45cb1961e4')
build() {
cd plotly.py-${pkgver}/packages/python/plotly
- SKIP_NPM=1 NODE_OPTIONS=--openssl-legacy-provider python setup.py build
+ SKIP_NPM=1 python setup.py build
}
check() {
@@ -55,6 +54,7 @@ check() {
package() {
cd plotly.py-${pkgver}/packages/python/plotly
SKIP_NPM=1 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ mv ${pkgdir}/usr/etc ${pkgdir}
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}