summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-02-02 16:23:42 +0000
committerGrey Christoforo2020-02-02 16:23:42 +0000
commitaebf1ed022e8e370c7cb521e0dd380b1ec4190e3 (patch)
tree7b06b18a4ab4b7dc4899eb8d873a80cfb2cfcf78
parent59e4a28f73c90fcd807f646afed026920cb6bd0c (diff)
downloadaur-aebf1ed022e8e370c7cb521e0dd380b1ec4190e3.tar.gz
bump version and drop python2
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
3 files changed, 32 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5e889c9bd0b..8b2f1464278e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,20 @@
pkgbase = python-plotly
- pkgdesc = An interactive, browser-based graphing library for Python
- pkgver = 4.1.0
+ pkgdesc = An open-source, interactive graphing library
+ pkgver = 4.5.0
pkgrel = 1
- url = https://plot.ly/python/
+ url = https://github.com/coin3d/pivy
arch = any
license = MIT
- makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
- makedepends = python-numpy
- makedepends = python-pytz
- makedepends = python-requests
- makedepends = python-retrying
- makedepends = python2-numpy
- makedepends = python2-pytz
- makedepends = python2-requests
- source = python-plotly-4.1.0.tar.gz::https://pypi.org/packages/source/p/plotly/plotly-4.1.0.tar.gz
- sha512sums = b7249ce8acc98d642ede4eec3f18cdd251969d8da9a1dba467afed40d84b568ac2f3c8471bb98b386dde82d027c1f9f03cdab6d8271fa85349a428f1a507dde1
-
-pkgname = python-plotly
- pkgdesc = An interactive, browser-based graphing library for Python3
depends = python
- depends = python-requests
- depends = python-pytz
- depends = python-six
+ depends = python-matplotlib
depends = python-numpy
+ depends = python-six
depends = python-retrying
+ optdepends = ipython
+ optdepends = python-ipywidgets
+ source = https://github.com/plotly/plotly.py/archive/v4.5.0.tar.gz
+ md5sums = 3f02b2337e062b6d367a1476c2300921
-pkgname = python2-plotly
- pkgdesc = An interactive, browser-based graphing library for Python2
- depends = python2
- depends = python2-requests
- depends = python2-pytz
- depends = python2-six
- depends = python2-numpy
- depends = python-retrying
+pkgname = python-plotly
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..32f0ae164510
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 4de8a52606f0..ce6ed519c2a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,26 @@
-# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
-# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
-# Contributor: fclad <fcladera at fcladera.com>
+# Maintainer: Grey Christoforo <first name at last name dot net>
-_pkgname=python-plotly
-_pypiname=plotly
-pkgbase=python-plotly
-pkgname=('python-plotly' 'python2-plotly')
-pkgdesc="An interactive, browser-based graphing library for Python"
-pkgver=4.1.0
+pkgname=python-plotly
+pkgver=4.5.0
pkgrel=1
-url="https://plot.ly/python/"
+pkgdesc="An open-source, interactive graphing library"
+url="https://github.com/coin3d/pivy"
+depends=('python' 'python-matplotlib' 'python-numpy' 'python-six' 'python-retrying')
+optdepends=('ipython' 'python-ipywidgets')
+makedepends=('python-setuptools')
license=('MIT')
-arch=("any")
-makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools' 'python-numpy' 'python-pytz' 'python-requests' 'python-retrying' 'python2-numpy' 'python2-pytz' 'python2-requests')
-source=("${_pkgname}-${pkgver}.tar.gz::https://pypi.org/packages/source/p/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
-sha512sums=('b7249ce8acc98d642ede4eec3f18cdd251969d8da9a1dba467afed40d84b568ac2f3c8471bb98b386dde82d027c1f9f03cdab6d8271fa85349a428f1a507dde1')
-#validpgpkeys=('') # TODO https://github.com/plotly/plotly.py/issues/764
+arch=('any')
+source=("https://github.com/plotly/plotly.py/archive/v${pkgver}.tar.gz")
+md5sums=('3f02b2337e062b6d367a1476c2300921')
-prepare() {
- # Create a copy for the python2 package
- cp -r "${_pypiname}-${pkgver}" "python2-${_pypiname}-${pkgver}"
+build() {
+ cd plotly.py-${pkgver}/packages/python/plotly
+ python setup.py build
}
-package_python-plotly() {
- pkgdesc="An interactive, browser-based graphing library for Python3"
- depends=('python' 'python-requests' 'python-pytz' 'python-six'
- 'python-numpy' 'python-retrying')
+package() {
+ cd plotly.py-${pkgver}/packages/python/plotly
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- cd "${srcdir}/${_pypiname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
-
- install -Dm644 "${srcdir}/${_pypiname}-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
-package_python2-plotly() {
- pkgdesc="An interactive, browser-based graphing library for Python2"
- depends=('python2' 'python2-requests' 'python2-pytz' 'python2-six'
- 'python2-numpy' 'python-retrying')
-
- cd "${srcdir}/python2-${_pypiname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
-
- install -Dm644 "${srcdir}/python2-${_pypiname}-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}