summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2023-01-13 18:24:19 +0000
committerGreyson Christoforo2023-01-13 18:24:19 +0000
commitb76f4c52af2c5bb2bf147411f64ead1d19d1273f (patch)
treee7414698dba850a0cd369bf5b18152842a17beb8
parent032a38db2f8cbe069f1953d30ec95491a375d3be (diff)
downloadaur-b76f4c52af2c5bb2bf147411f64ead1d19d1273f.tar.gz
build with SKIP_NPM=1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b44f8622020f..382a96e8e5c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-plotly
pkgdesc = An open-source, interactive graphing library
pkgver = 5.12.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/plotly/plotly.py
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index b04fc30c80d5..1daab4c0df88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-plotly
pkgver=5.12.0
-pkgrel=2
+pkgrel=3
pkgdesc="An open-source, interactive graphing library"
arch=('x86_64')
url="https://github.com/plotly/plotly.py"
@@ -44,7 +44,7 @@ sha256sums=('33548f8abc3310acde8ba7d74a57a652ed278ef5c4a999a61ae9fb45cb1961e4')
build() {
cd plotly.py-${pkgver}/packages/python/plotly
- NODE_OPTIONS=--openssl-legacy-provider python setup.py build
+ SKIP_NPM=1 NODE_OPTIONS=--openssl-legacy-provider python setup.py build
}
check() {
@@ -54,7 +54,7 @@ check() {
package() {
cd plotly.py-${pkgver}/packages/python/plotly
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ SKIP_NPM=1 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}