summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2021-06-28 22:34:38 +0100
committerGrey Christoforo2021-06-28 22:34:38 +0100
commitf7d399e99e9ad41685e17016b0862271579ab70c (patch)
treee5672d5e580320c3284525578b771b0c07f76ea4
parent04e37446d3755d976ca9a9b6afd7758668957197 (diff)
downloadaur-f7d399e99e9ad41685e17016b0862271579ab70c.tar.gz
bump version, add mising dep
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ca3e91821bb..6b55930ed7ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = python-plotly
pkgdesc = An open-source, interactive graphing library
- pkgver = 5.0.0
+ pkgver = 5.1.0
pkgrel = 1
url = https://github.com/plotly/plotly.py
- arch = any
+ arch = x86_64
license = MIT
makedepends = python-setuptools
depends = python
+ depends = jupyterlab
depends = python-matplotlib
depends = python-numpy
depends = python-six
depends = python-retrying
optdepends = ipython
optdepends = python-ipywidgets
- source = python-plotly-5.0.0.tar.gz::https://github.com/plotly/plotly.py/archive/v5.0.0.tar.gz
- sha256sums = 0bac50ca5744d465479d0304c608eba1abb5ce5fc0f1b07790cc58ebd42427cd
+ source = python-plotly-5.1.0.tar.gz::https://github.com/plotly/plotly.py/archive/v5.1.0.tar.gz
+ sha256sums = ed17ece01fc462c5e257567241fda1d202e3cac8c27fa44185bd680bb1457f02
pkgname = python-plotly
diff --git a/PKGBUILD b/PKGBUILD
index db31e77cc1aa..36818b904b1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=python-plotly
-pkgver=5.0.0
+pkgver=5.1.0
pkgrel=1
pkgdesc="An open-source, interactive graphing library"
url="https://github.com/plotly/plotly.py"
-depends=('python' 'python-matplotlib' 'python-numpy' 'python-six' 'python-retrying')
+depends=(python
+jupyterlab
+python-matplotlib
+python-numpy
+python-six
+python-retrying)
optdepends=('ipython' 'python-ipywidgets')
makedepends=('python-setuptools')
license=('MIT')
-arch=('any')
+arch=('x86_64')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/plotly/plotly.py/archive/v${pkgver}.tar.gz")
-sha256sums=('0bac50ca5744d465479d0304c608eba1abb5ce5fc0f1b07790cc58ebd42427cd')
+sha256sums=('ed17ece01fc462c5e257567241fda1d202e3cac8c27fa44185bd680bb1457f02')
build() {
cd plotly.py-${pkgver}/packages/python/plotly