summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A.2023-10-20 10:39:41 +0200
committerPhilipp A.2023-10-20 10:39:41 +0200
commit09bbefb04795eb0bc9115e5c031a2427f1f2f80d (patch)
treea194ef94192239bee9fd3ce083ba4a0d1bf7061c
parent3f45fb856a6a58681773b9a5d2bb1e294beb862f (diff)
downloadaur-09bbefb04795eb0bc9115e5c031a2427f1f2f80d.tar.gz
v0.12.3
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD67
3 files changed, 71 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf5abff0f53..9df90114d8e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,31 @@
pkgbase = python-plotnine
pkgdesc = A grammar of graphics for python
- pkgver = 0.10.1
+ pkgver = 0.12.3
pkgrel = 1
url = https://github.com/has2k1/plotnine
arch = any
- license = GPL2
+ license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ checkdepends = python-vcrpy
+ checkdepends = python-geopandas
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- depends = python-mizani>=0.7.3
- depends = python-matplotlib>=3.1.1
- depends = python-numpy>=1.19.0
- depends = python-scipy>=1.5.0
+ depends = python-matplotlib>=3.6.0
+ depends = python-mizani<=0.11.0
+ depends = python-numpy>=1.23.0
+ depends = python-pandas>=1.5.0
depends = python-patsy>=0.5.1
- depends = python-statsmodels>=0.12.1
- depends = python-pandas>=1.1.0
- depends = python-descartes>=1.1.0
+ depends = python-scipy>=1.5.0
+ depends = python-statsmodels>=0.14.0
+ optdepends = python-adjusttext: Library to avoid/minimize text overlaps in plots
+ optdepends = python-geopandas: Geospatial data support
optdepends = python-scikit-learn: gaussian process smoothing, kernel density implementation
- optdepends = python-scikit-misc: loess smooting
- noextract = plotnine-0.10.1-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/p/plotnine/plotnine-0.10.1-py3-none-any.whl
- sha256sums = bac216d71b04ea4e084a529c08716a981fe073c8fcdafa7643043935d7b7fa9d
+ optdepends = python-scikit-misc: loess smoothing
+ optdepends = python-shapely: Manipulation and analysis of geometric objects in the Cartesian plane
+ source = https://files.pythonhosted.org/packages/source/p/plotnine/plotnine-0.12.3.tar.gz
+ sha256sums = a38dcb3607fc003c1e59ae0c9d535dae7817650d1cbc2e56e56e5b3de88dfe99
pkgname = python-plotnine
diff --git a/.gitignore b/.gitignore
index 4d7ad300862e..8bba9d8c732d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.whl
+/*.tar.gz
/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index b7b31c211592..d32b967a4310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,65 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+# Contributor: Torleif Skår <torleif.skaar AT gmail DOT com>
+
_name=plotnine
pkgname=python-$_name
-pkgver=0.10.1
+pkgver=0.12.3
pkgrel=1
pkgdesc='A grammar of graphics for python'
arch=(any)
url="https://github.com/has2k1/$_name"
-license=(GPL2)
+license=('MIT')
depends=(
python
- 'python-mizani>=0.7.3'
- 'python-matplotlib>=3.1.1'
- 'python-numpy>=1.19.0'
- 'python-scipy>=1.5.0'
+ 'python-matplotlib>=3.6.0'
+ 'python-mizani<=0.11.0'
+ 'python-numpy>=1.23.0'
+ 'python-pandas>=1.5.0'
'python-patsy>=0.5.1'
- 'python-statsmodels>=0.12.1'
- 'python-pandas>=1.1.0'
- 'python-descartes>=1.1.0'
+ 'python-scipy>=1.5.0'
+ 'python-statsmodels>=0.14.0'
)
+
optdepends=(
+ 'python-adjusttext: Library to avoid/minimize text overlaps in plots'
+ 'python-geopandas: Geospatial data support'
'python-scikit-learn: gaussian process smoothing, kernel density implementation'
- 'python-scikit-misc: loess smooting'
+ 'python-scikit-misc: loess smoothing'
+ 'python-shapely: Manipulation and analysis of geometric objects in the Cartesian plane'
+)
+
+makedepends=(
+ python-build
+ python-installer
+ python-wheel
+)
+
+checkdepends=(
+ python-pytest
+ python-pytest-cov
+ python-vcrpy
+ python-geopandas
)
-_pyarch=py3
-_wheel="$_name-$pkgver-$_pyarch-none-any.whl"
-source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
-noextract=("$_wheel")
-sha256sums=('bac216d71b04ea4e084a529c08716a981fe073c8fcdafa7643043935d7b7fa9d')
+
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('a38dcb3607fc003c1e59ae0c9d535dae7817650d1cbc2e56e56e5b3de88dfe99')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+# Image tests are flaky, skip by default
+BUILDENV+=('!check')
+
+check() {
+ cd "${_name}-${pkgver}"
+ # skip because of ImportError: cannot import name 'log_format' from 'mizani.transforms'
+ PYTHONPATH=. pytest --ignore=tests/test_annotation_logticks.py
+}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
+ cd "${_name}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm0644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" LICENSE
}