summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEndlessEden2021-08-21 14:59:12 +1000
committerEndlessEden2021-08-21 14:59:12 +1000
commit29f146156fc28cdd6cc0cec536dbb0bdf092144f (patch)
tree9f837c65e707e6abc3381d362e5db51f26bb45fd
parent4b208882bf55ef9028ae7665aebf9f1816801ac6 (diff)
downloadaur-29f146156fc28cdd6cc0cec536dbb0bdf092144f.tar.gz
Typos: Depends/provides/conflicts Updated
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 612258debcdf..d5bca46d6085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,14 +25,33 @@ pkgbase = python-pocketsphinx-git
sha512sums = SKIP
pkgname = python-pocketsphinx-git
+ depends = pocketsphinx
+ provides = python-pocketsphinx
+ provides = python-pocketsphinx-git
+ provides = python3-pocketsphinx
+ provides = python3-pocketsphinx-git
+ conflicts = python-pocketsphinx
+ conflicts = python-pocketsphinx-git
+ conflicts = python3-pocketsphinx
+ conflicts = python3-pocketsphinx-git
pkgname = python2-pocketsphinx-git
+ depends = pocketsphinx
+ provides = python2-pocketsphinx
+ provides = python2-pocketsphinx-git
+ conflicts = python2-pocketsphinx
+ conflicts = python2-pocketsphinx-git
pkgname = sphinxbase-git
provides = sphinxbase
+ provides = sphinxbase-git
conflicts = sphinxbase
+ conflicts = sphinxbase-git
pkgname = pocketsphinx-git
+ depends = sphinxbase-git
depends = sphinxbase
provides = pocketsphinx
- conflicts = procketsphinx
+ provides = pocketsphinx-git
+ conflicts = pocketsphinx
+ conflicts = pocketsphinx-git
diff --git a/PKGBUILD b/PKGBUILD
index 9c89100b54f9..d99cfdcee96e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,8 +67,8 @@ build() {
}
package_sphinxbase-git() {
- provides=('sphinxbase')
- conflicts=('sphinxbase')
+ provides=('sphinxbase' 'sphinxbase-git')
+ conflicts=('sphinxbase' 'sphinxbase-git')
cd "${srcdir}/${_gitname}/deps/sphinxbase"
export PYTHON=/usr/bin/python
@@ -81,9 +81,9 @@ package_sphinxbase-git() {
}
package_pocketsphinx-git() {
- provides=('pocketsphinx')
- conflicts=('procketsphinx')
- depends=('sphinxbase')
+ provides=('pocketsphinx' 'pocketsphinx-git')
+ conflicts=('pocketsphinx' 'pocketsphinx-git')
+ depends=('sphinxbase-git' 'sphinxbase')
# Pocketsphinx needs libpocketsphinx which is located in the other package
# (sphinxbase). Copy the libs temporarily just to allow linking. Then
@@ -111,6 +111,10 @@ package_pocketsphinx-git() {
}
package_python-pocketsphinx-git() {
+ provides=('python-pocketsphinx' 'python-pocketsphinx-git' 'python3-pocketsphinx' 'python3-pocketsphinx-git')
+ conflicts=('python-pocketsphinx' 'python-pocketsphinx-git' 'python3-pocketsphinx' 'python3-pocketsphinx-git')
+ depends=('pocketsphinx')
+
cd "${srcdir}/${_gitname}"
export PYTHON=/usr/bin/python
@@ -118,6 +122,10 @@ package_python-pocketsphinx-git() {
}
package_python2-pocketsphinx-git() {
+ provides=('python2-pocketsphinx' 'python2-pocketsphinx-git')
+ conflicts=('python2-pocketsphinx' 'python2-pocketsphinx-git')
+ depends=('pocketsphinx')
+
export PYTHON=/usr/bin/python2
cd "${srcdir}/python2-pocketsphinx-git/deps/sphinxbase"