summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago França da Silva2020-12-20 13:01:06 -0300
committerThiago França da Silva2020-12-20 13:01:06 -0300
commit3f54832a26dd09e63878a68b5e58dd017ca5d972 (patch)
treeca0df37488b54102e70c16ba0773cb11bfc3e5d4
parent85e020802f02acc52fa3bbe68971ebbf370cdd74 (diff)
downloadaur-3f54832a26dd09e63878a68b5e58dd017ca5d972.tar.gz
remove patch and change clikit to clikit-git
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Suppress-dependency-versions-which-are-known-to-be-t.patch42
-rw-r--r--PKGBUILD9
3 files changed, 4 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60ec418ebbb9..43ab313615b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-poetry-git
pkgdesc = Python dependency management and packaging made easy
- pkgver = 1.1.0b2.r41.g9fe44933
+ pkgver = 1.1.0.r73.gbf30ca69
pkgrel = 1
url = https://python-poetry.org/
arch = any
@@ -13,7 +13,7 @@ pkgbase = python-poetry-git
depends = python-cachecontrol
depends = python-cachy
depends = python-cleo
- depends = python-clikit>=0.6.2
+ depends = python-clikit-git
depends = python-html5lib
depends = python-jsonschema
depends = python-lockfile
@@ -34,10 +34,8 @@ pkgbase = python-poetry-git
conflicts = python-poetry
replaces = poetry
source = poetry::git+https://github.com/python-poetry/poetry.git
- source = 0001-Suppress-dependency-versions-which-are-known-to-be-t.patch
source = poetry-completions-generator
sha256sums = SKIP
- sha256sums = 3f992187e7dfbbb5a8d0667ff40ff7b6c3056825291e8a675cf456f8c4fde1d0
sha256sums = 970225289188ea8dc49fbec8a2bfe0c891aee80ff56ba6e69bdd8afef8bccab6
pkgname = python-poetry-git
diff --git a/0001-Suppress-dependency-versions-which-are-known-to-be-t.patch b/0001-Suppress-dependency-versions-which-are-known-to-be-t.patch
deleted file mode 100644
index 029859535e95..000000000000
--- a/0001-Suppress-dependency-versions-which-are-known-to-be-t.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/pyproject.toml b/pyproject.toml
-index e2296a3c..59923b0a 100644
---- a/pyproject.toml
-+++ b/pyproject.toml
-@@ -30,12 +30,12 @@ clikit = "^0.6.2"
- crashtest = { version = "^0.3.0", python = "^3.6" }
- requests = "^2.18"
- cachy = "^0.3.0"
--requests-toolbelt = "^0.8.0"
-+requests-toolbelt = "*"
- cachecontrol = { version = "^0.12.4", extras = ["filecache"] }
- pkginfo = "^1.4"
- html5lib = "^1.0"
- shellingham = "^1.1"
--tomlkit = ">=0.7.0,<1.0.0"
-+tomlkit = "*"
- pexpect = "^4.7.0"
- packaging = "^20.4"
- virtualenv = { version = "^20.0.26" }
-@@ -51,20 +51,13 @@ futures = { version = "^3.3.0", python = "~2.7" }
- glob2 = { version = "^0.6", python = "~2.7" }
- # functools32 is needed for Python 2.7
- functools32 = { version = "^3.2.3", python = "~2.7" }
--keyring = [
-- { version = "^18.0.1", python = "~2.7" },
-- { version = "^20.0.1", python = "~3.5" },
-- { version = "^21.2.0", python = "^3.6" }
--]
-+keyring = "*"
- # Use subprocess32 for Python 2.7
- subprocess32 = { version = "^3.5", python = "~2.7" }
- importlib-metadata = {version = "^1.6.0", python = "<3.8"}
-
- [tool.poetry.dev-dependencies]
--pytest = [
-- {version = "^4.1", python = "<3.5"},
-- {version = "^5.4.3", python = ">=3.5"}
--]
-+pytest = "*"
- pytest-cov = "^2.5"
- pytest-mock = "^1.9"
- pre-commit = { version = "^2.6", python = "^3.6.1" }
diff --git a/PKGBUILD b/PKGBUILD
index 421769bd5d91..a2b78845e2aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=poetry
pkgname=python-poetry-git
-pkgver=1.1.0b2.r41.g9fe44933
+pkgver=1.1.0.r73.gbf30ca69
pkgrel=1
pkgdesc="Python dependency management and packaging made easy"
arch=('any')
url="https://python-poetry.org/"
license=('MIT')
-_deps=('cachecontrol' 'cachy' 'cleo' 'clikit>=0.6.2' 'html5lib' 'jsonschema' 'lockfile'
+_deps=('cachecontrol' 'cachy' 'cleo' 'clikit-git' 'html5lib' 'jsonschema' 'lockfile'
'pkginfo' 'pyparsing' 'pyrsistent' 'requests' 'requests-toolbelt'
'shellingham' 'tomlkit' 'keyring' 'pexpect' 'poetry-core-git' 'virtualenv>=20.0.26')
depends=("${_deps[@]/#/python-}")
@@ -18,10 +18,8 @@ provides=('poetry' 'python-poetry')
conflicts=('poetry' 'python-poetry')
replaces=('poetry')
source=("${_pkgname}"::"git+https://github.com/python-${_pkgname}/${_pkgname}.git"
- "0001-Suppress-dependency-versions-which-are-known-to-be-t.patch"
"poetry-completions-generator")
sha256sums=('SKIP'
- '3f992187e7dfbbb5a8d0667ff40ff7b6c3056825291e8a675cf456f8c4fde1d0'
'970225289188ea8dc49fbec8a2bfe0c891aee80ff56ba6e69bdd8afef8bccab6')
pkgver() {
@@ -35,9 +33,6 @@ pkgver() {
prepare() {
cd "${srcdir}"/${_pkgname}
- # fix various overly restrictive version pinning
- patch -p1 -i ../0001-Suppress-dependency-versions-which-are-known-to-be-t.patch
-
dephell deps convert --level DEBUG --from pyproject.toml --to setup.py
}