summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago França da Silva2021-02-02 17:16:32 -0300
committerThiago França da Silva2021-02-02 17:16:32 -0300
commita69c63279e12d90234c2eaf91c5d2856453ba1eb (patch)
tree1bfee0acb1f623a1f0ba70cefa586540eed1bd18
parent3f54832a26dd09e63878a68b5e58dd017ca5d972 (diff)
downloadaur-a69c63279e12d90234c2eaf91c5d2856453ba1eb.tar.gz
drop clikit change to python-cleo-git and change poetry.console to poetry.console.application
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xpoetry-completions-generator2
3 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43ab313615b8..6e48b6aa0fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-poetry-git
pkgdesc = Python dependency management and packaging made easy
- pkgver = 1.1.0.r73.gbf30ca69
+ pkgver = 1.1.0.r85.g855bc88b
pkgrel = 1
url = https://python-poetry.org/
arch = any
@@ -12,8 +12,7 @@ pkgbase = python-poetry-git
makedepends = python-dephell
depends = python-cachecontrol
depends = python-cachy
- depends = python-cleo
- depends = python-clikit-git
+ depends = python-cleo-git
depends = python-html5lib
depends = python-jsonschema
depends = python-lockfile
@@ -36,7 +35,6 @@ pkgbase = python-poetry-git
source = poetry::git+https://github.com/python-poetry/poetry.git
source = poetry-completions-generator
sha256sums = SKIP
- sha256sums = 970225289188ea8dc49fbec8a2bfe0c891aee80ff56ba6e69bdd8afef8bccab6
+ sha256sums = e44c71a3b804b5c2bf07573ed465aee275a5844f10e37ee63c7395c9213a2b6d
pkgname = python-poetry-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a2b78845e2aa..ba24056b0b34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=poetry
pkgname=python-poetry-git
-pkgver=1.1.0.r73.gbf30ca69
+pkgver=1.1.0.r85.g855bc88b
pkgrel=1
pkgdesc="Python dependency management and packaging made easy"
arch=('any')
url="https://python-poetry.org/"
license=('MIT')
-_deps=('cachecontrol' 'cachy' 'cleo' 'clikit-git' 'html5lib' 'jsonschema' 'lockfile'
+_deps=('cachecontrol' 'cachy' 'cleo-git' 'html5lib' 'jsonschema' 'lockfile'
'pkginfo' 'pyparsing' 'pyrsistent' 'requests' 'requests-toolbelt'
'shellingham' 'tomlkit' 'keyring' 'pexpect' 'poetry-core-git' 'virtualenv>=20.0.26')
depends=("${_deps[@]/#/python-}")
@@ -20,7 +20,7 @@ replaces=('poetry')
source=("${_pkgname}"::"git+https://github.com/python-${_pkgname}/${_pkgname}.git"
"poetry-completions-generator")
sha256sums=('SKIP'
- '970225289188ea8dc49fbec8a2bfe0c891aee80ff56ba6e69bdd8afef8bccab6')
+ 'e44c71a3b804b5c2bf07573ed465aee275a5844f10e37ee63c7395c9213a2b6d')
pkgver() {
cd "${srcdir}/${_pkgname}"
diff --git a/poetry-completions-generator b/poetry-completions-generator
index e0a1d3929aeb..3863380b1939 100755
--- a/poetry-completions-generator
+++ b/poetry-completions-generator
@@ -8,7 +8,7 @@
# We don't want to complete 'poetry/__main__.py'....
import sys
-from poetry.console import main
+from poetry.console.application import main
sys.argv = ['poetry', 'completions', sys.argv.pop()]