diff options
author | Alexandre Bury | 2022-08-23 10:25:00 -0400 |
---|---|---|
committer | Alexandre Bury | 2022-08-23 10:25:00 -0400 |
commit | 93480ebd398dc74eee18f0fa32aa032aa41ccf19 (patch) | |
tree | 1362d8ea5921c8564c6004c73b001f94daf7686e | |
parent | b7b16e76328d24895813da9f3859847d3135167a (diff) | |
download | aur-93480ebd398dc74eee18f0fa32aa032aa41ccf19.tar.gz |
Use tar.gz instead of zip
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 4 | ||||
-rwxr-xr-x | update.sh | 2 |
3 files changed, 5 insertions, 5 deletions
@@ -15,7 +15,7 @@ pkgbase = python-polars optdepends = python-pyarrow: for interoperability with arrow types optdepends = python-pytz: to enable conversion to python datetimes with timezones optdepends = python-fsspec: to transparently open files locally or remotely - source = https://github.com/pola-rs/polars/archive/refs/tags/py-polars-v0.14.5.zip - b2sums = 59f03f0a981218d80475f37ee722b3504c9ed214789cfc5969b778da8c34e7fa932e53ca7ec264371e6e840c96fb1d9a9188f654236d0ef094efdfdab4444465 + source = https://github.com/pola-rs/polars/archive/refs/tags/py-polars-v0.14.5.tar.gz + b2sums = 8e48fff1c535edabbbd3fa1ec722098b6e47df62863e525af9abe48cb9c063e317c478e5eb640b7b16055b3e4d7ce608b39bfd33fc869389f2ebbcb6ec995aed pkgname = python-polars @@ -14,8 +14,8 @@ optdepends=('python-pandas: for interoperability with pandas frames' 'python-fsspec: to transparently open files locally or remotely') makedepends=('maturin' 'rust-nightly' 'cmake' 'python-installer') _name=${pkgname#python-} -source=("https://github.com/pola-rs/polars/archive/refs/tags/py-polars-v$pkgver.zip") -b2sums=("59f03f0a981218d80475f37ee722b3504c9ed214789cfc5969b778da8c34e7fa932e53ca7ec264371e6e840c96fb1d9a9188f654236d0ef094efdfdab4444465") +source=("https://github.com/pola-rs/polars/archive/refs/tags/py-polars-v$pkgver.tar.gz") +b2sums=("8e48fff1c535edabbbd3fa1ec722098b6e47df62863e525af9abe48cb9c063e317c478e5eb640b7b16055b3e4d7ce608b39bfd33fc869389f2ebbcb6ec995aed") build() { rm wheels -rf diff --git a/update.sh b/update.sh index 1cc5f4284997..94d36f95a8e7 100755 --- a/update.sh +++ b/update.sh @@ -21,7 +21,7 @@ if [ "$pkgver" == "$LAST" ]; then exit 0 fi -DOWNLOAD_URL="https://github.com/pola-rs/polars/archive/refs/tags/py-polars-v$LAST.zip" +DOWNLOAD_URL="https://github.com/pola-rs/polars/archive/refs/tags/py-polars-v$LAST.tar.gz" SUM=$(curl -sL $DOWNLOAD_URL | $HASH - | cut -d' ' -f1) sed -i 's/.*sums=.*$/'$HASH_NAME'=("'$SUM'")/' PKGBUILD |