summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-08 13:59:15 +0800
committerUniversebenzene2019-08-08 13:59:15 +0800
commit983a8c5fada0374fcc82adcacc159f32eea8b798 (patch)
treedbb6e61a70a55378f849d3ded11c2fab67696df1
parent7542c37abf4c77217dcbbe1541263ee3a3b4ec65 (diff)
downloadaur-983a8c5fada0374fcc82adcacc159f32eea8b798.tar.gz
Update to version 0.13.0
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD7
3 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75d7284ef7a8..f6c1fdc39b0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Feb 22 05:47:14 UTC 2019
pkgbase = python-poliastro
pkgdesc = Astrodynamics and Orbital Mechanics computations
- pkgver = 0.12.0
+ pkgver = 0.13.0
pkgrel = 1
url = http://docs.poliastro.space/
arch = i686
@@ -19,16 +17,15 @@ pkgbase = python-poliastro
checkdepends = python-jplephem
checkdepends = python-numba
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/p/poliastro/poliastro-0.12.0.tar.gz
- md5sums = 92ceb28714723ae63381d8a241b9aad9
+ source = https://files.pythonhosted.org/packages/source/p/poliastro/poliastro-0.13.0.tar.gz
+ md5sums = db19b3509d1f288caef8b9dd5bd02e23
pkgname = python-poliastro
- depends = python>=3.5
+ depends = python>=3.6
depends = python-astropy
depends = python-jplephem
depends = python-matplotlib
depends = python-plotly
- depends = python-retrying
optdepends = python-numba: For accelerating the code
optdepends = python-poliastro-doc: Documentation for poliastro
optdepends = python-pandas
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1df7b618a7b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index eb292a902793..7cb78cd34cda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-poliastro
_pyname=${pkgname#python-}
-pkgver=0.12.0
+pkgver=0.13.0
pkgrel=1
pkgdesc="Astrodynamics and Orbital Mechanics computations"
arch=('i686' 'x86_64')
@@ -19,7 +19,7 @@ checkdepends=('python-pytest'
'python-jplephem'
'python-numba')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('92ceb28714723ae63381d8a241b9aad9')
+md5sums=('db19b3509d1f288caef8b9dd5bd02e23')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -34,7 +34,8 @@ check() {
}
package() {
- depends=('python>=3.5' 'python-astropy' 'python-jplephem' 'python-matplotlib' 'python-plotly' 'python-retrying')
+ depends=('python>=3.6' 'python-astropy' 'python-jplephem' 'python-matplotlib' 'python-plotly')
+ #'python-retrying')
optdepends=('python-numba: For accelerating the code'
'python-poliastro-doc: Documentation for poliastro'
'python-pandas'