summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-18 18:13:42 -0500
committerclintval2017-12-18 18:13:42 -0500
commit1d40ce36f72b82c080b545a2dfa467489fd9aa63 (patch)
treedf50f6276d0b15edb367cb69aac76fac8a61a550
downloadaur-1d40ce36f72b82c080b545a2dfa467489fd9aa63.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..282b58e6e3f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-polo
+ pkgdesc = Python optimal leaf ordering for hierarchical clustering
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/adrianveres/polo
+ arch = any
+ license = MIT
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy>=1.9.2
+ depends = python-scipy
+ provides = python-polo
+ conflicts = python-polo
+ options = !emptydirs
+ source = https://github.com/adrianveres/polo/archive/0.4.tar.gz
+ md5sums = a5d3d2b09b18b34b4e368b1936197fd6
+
+pkgname = python-polo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c98ad4b45a4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-polo'
+pkgver=0.4
+pkgrel=1
+pkgdesc="Python optimal leaf ordering for hierarchical clustering"
+arch=('any')
+url="https://github.com/adrianveres/polo"
+license=('MIT')
+depends=('python' 'python-numpy>=1.9.2' 'python-scipy')
+makedepends=('cython' 'python-setuptools')
+provides=('python-polo')
+conflicts=('python-polo')
+options=(!emptydirs)
+source=("https://github.com/adrianveres/polo/archive/${pkgver}.tar.gz")
+md5sums=('a5d3d2b09b18b34b4e368b1936197fd6')
+
+package() {
+ cd "${srcdir}/polo-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}