summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-04-24 18:18:35 +0200
committerPhilip Goto2020-04-24 18:18:35 +0200
commit4b27aa559efc169045d2c3b9091df2cdf4aba600 (patch)
tree4d3a68954aa408ab9465dda7060e87a144c2df4e
downloadaur-4b27aa559efc169045d2c3b9091df2cdf4aba600.tar.gz
Initialize package
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD24
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b5a5a124f59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-polyscope
+ pkgdesc = Python viewer and user interface for 3D data, like meshes and point clouds
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://polyscope.run/py/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = cmake
+ makedepends = libglvnd
+ makedepends = libxi
+ makedepends = libxcursor
+ makedepends = libxinerama
+ makedepends = libxrandr
+ makedepends = python-setuptools
+ depends = gcc-libs
+ depends = libx11
+ source = https://files.pythonhosted.org/packages/58/bc/420255d2142e2e88d42fb17673867e23f2a82d255b0db3c204bf4cb4aa92/polyscope-0.1.2.tar.gz
+ sha256sums = eceecaf3762f1b785726dab2696d23dfd353a43adac032924066a596ebc711b3
+
+pkgname = python-polyscope
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9961f0766140
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=python-polyscope
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Python viewer and user interface for 3D data, like meshes and point clouds"
+url="https://polyscope.run/py/"
+depends=(gcc-libs libx11)
+makedepends=(cmake libglvnd libxi libxcursor libxinerama libxrandr python-setuptools)
+license=(MIT)
+arch=(i686 x86_64 armv6h armv7h)
+source=("https://files.pythonhosted.org/packages/58/bc/420255d2142e2e88d42fb17673867e23f2a82d255b0db3c204bf4cb4aa92/polyscope-0.1.2.tar.gz")
+sha256sums=('eceecaf3762f1b785726dab2696d23dfd353a43adac032924066a596ebc711b3')
+
+build(){
+ cd "polyscope-${pkgver}"
+ python setup.py build
+}
+
+package(){
+ cd "polyscope-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}