summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2016-12-11 13:33:14 -0500
committerBen Wolsieffer2016-12-11 13:34:49 -0500
commit6935617dcadcda7c4d3465bef23cdc02c222343c (patch)
treefe7b6afc87c32bef81ab509ff3894f3b5f6bb7d2
downloadaur-6935617dcadcda7c4d3465bef23cdc02c222343c.tar.gz
Create package based off of python2-port-for
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d43f0d88341b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Dec 11 18:33:11 UTC 2016
+pkgbase = python-port-for
+ pkgdesc = Utility that helps with local TCP ports managment. It can find an unused TCP localhost port and remember the association.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/kmike/port-for/
+ arch = any
+ license = MIT
+ depends = python
+ options = !emptydirs
+ source = https://pypi.io/packages/source/p/port-for/port-for-0.3.1.tar.gz
+ sha256sums = b16a84bb29c2954db44c29be38b17c659c9c27e33918dec16b90d375cc596f1c
+
+pkgname = python-port-for
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c7a155e89a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
+pkgname=python-port-for
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Utility that helps with local TCP ports managment. It can find an unused TCP localhost port and remember the association."
+arch=('any')
+url="https://github.com/kmike/port-for/"
+license=('MIT')
+depends=('python')
+options=(!emptydirs)
+source=(https://pypi.io/packages/source/p/port-for/port-for-$pkgver.tar.gz)
+sha256sums=('b16a84bb29c2954db44c29be38b17c659c9c27e33918dec16b90d375cc596f1c')
+
+package() {
+ cd "$srcdir/port-for-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=4 sw=4 et: