summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Röthke2021-05-03 09:00:51 +0200
committerMarcel Röthke2021-05-03 09:00:51 +0200
commitccc7e047bb644a7efac230a8258ee654994fe1ec (patch)
tree288d4b98d46c0e0713afabf149dd55286f1c832a
parentae7b0c96e555b7f9420c41c22c715057addb4793 (diff)
downloadaur-ccc7e047bb644a7efac230a8258ee654994fe1ec.tar.gz
python-posix_ipc: upstream release 1.0.5-1 and PKGBUILD fixes
- Remove any from arch and set proper arches - Add license file to package - Separate build from package
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c116443cc336..8f39e475964b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = python-posix_ipc
pkgdesc = POSIX IPC primitives (semaphores, shared memory and message queues) for Python
- pkgver = 1.0.4
+ pkgver = 1.0.5
pkgrel = 1
url = http://semanchuk.com/philip/posix_ipc/
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = aarch64
license = BSD
makedepends = python-distribute
depends = python
options = !emptydirs
- source = http://semanchuk.com/philip/posix_ipc/posix_ipc-1.0.3.tar.gz
- sha1sums = 93bb5606a626a7a43c990d9fe4ade3512b515685
+ source = http://semanchuk.com/philip/posix_ipc/posix_ipc-1.0.5.tar.gz
+ sha1sums = 08b095e560b7514b9e2b7de2d791c4f9d578cda9
pkgname = python-posix_ipc
diff --git a/PKGBUILD b/PKGBUILD
index 995d7af429bf..47345e70c4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Frank Motsch <frank@motschsoft.de>
pkgname=python-posix_ipc
-pkgver=1.0.4
+pkgver=1.0.5
pkgrel=1
pkgdesc="POSIX IPC primitives (semaphores, shared memory and message queues) for Python"
-arch=('any')
+arch=(x86_64 i686 aarch64)
url="http://semanchuk.com/philip/posix_ipc/"
license=('BSD')
groups=()
@@ -11,9 +11,19 @@ depends=('python')
makedepends=('python-distribute')
options=(!emptydirs)
source=("http://semanchuk.com/philip/posix_ipc/posix_ipc-$pkgver.tar.gz")
-sha1sums=('93bb5606a626a7a43c990d9fe4ade3512b515685')
+sha1sums=('08b095e560b7514b9e2b7de2d791c4f9d578cda9')
+
+build() {
+ cd "$srcdir/posix_ipc-$pkgver"
+
+ python setup.py build
+
+}
package() {
-cd "$srcdir/posix_ipc-$pkgver"
-python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/posix_ipc-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}