summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHao Zhang2015-07-07 23:36:29 -0400
committerHao Zhang2015-07-07 23:36:29 -0400
commit42d81ba5bcfbeba8994fe4d170a530c4834eda11 (patch)
tree7b5fe5360f1b50e028fe743385ee4628e9ceca89
downloadaur-42d81ba5bcfbeba8994fe4d170a530c4834eda11.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae3ba90d7304
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-postfix-policyd-spf
+ pkgdesc = Python Postfix Sender Policy Framework (SPF) filter
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://launchpad.net/pypolicyd-spf/
+ arch = any
+ license = GPL
+ depends = postfix
+ depends = python-pyspf
+ depends = python>=3.3
+ optdepends = python-authres: RFC 7001 Authentication-Results header support
+ conflicts = python2-postfix-policyd-spf
+ options = !emptydirs
+ backup = etc/python-policyd-spf/policyd-spf.conf
+ source = https://launchpad.net/pypolicyd-spf/1.3/1.3.1/+download/pypolicyd-spf-1.3.1.tar.gz
+ md5sums = c847a4deecb7405ff4a6778fb971cbd1
+
+pkgname = python-postfix-policyd-spf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf67d5df6f3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Hao Zhang <theivorytower [at] gmail [dot] com>
+# Based on python2-postfix-policyd-spf PKGBUILD by Filip S. Adamsen <fsa [at] fsadev [dot] com>
+# Contributor: Samed Beyribey <ras0ir@eventualis.org>
+pkgname=python-postfix-policyd-spf
+_pkgname=pypolicyd-spf
+pkgver=1.3.1
+_pkgver=1.3
+pkgrel=1
+pkgdesc="Python Postfix Sender Policy Framework (SPF) filter"
+arch=('any')
+url="https://launchpad.net/pypolicyd-spf/"
+license=('GPL')
+depends=('postfix' 'python-pyspf' 'python>=3.3')
+optdepends=('python-authres: RFC 7001 Authentication-Results header support')
+conflicts=('python2-postfix-policyd-spf')
+options=(!emptydirs)
+backup=(etc/python-policyd-spf/policyd-spf.conf)
+source=(https://launchpad.net/$_pkgname/$_pkgver/$pkgver/+download/$_pkgname-$pkgver.tar.gz)
+md5sums=('c847a4deecb7405ff4a6778fb971cbd1')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ python setup.py build || return 1
+ }
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir/ --optimize=1 || return 1
+ install -m644 policyd-spf.conf.commented $pkgdir/etc/python-policyd-spf || return 1
+}
+