summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothée Ravier2015-07-18 17:50:48 +0200
committerTimothée Ravier2015-07-18 17:50:48 +0200
commit23cac88ed48030565426ace365af62e820089706 (patch)
tree1cb57a117006c6f1e177e0348dd827705d956c44
downloadaur-23cac88ed48030565426ace365af62e820089706.tar.gz
Imported from the AURv3, merged with python2 version
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD81
-rw-r--r--powerline.install43
3 files changed, 161 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..697248b00b50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = python-powerline-git
+ pkgdesc = The ultimate statusline/prompt utility
+ pkgver = 2381.03195cf
+ pkgrel = 1
+ url = https://github.com/powerline/powerline
+ install = powerline.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = powerline::git://github.com/powerline/powerline.git#branch=develop
+ source = powerline.install
+ sha256sums = SKIP
+ sha256sums = af07852748ddba1544feee53fdf747d3dd163597f026719f8a6f80045d0c5425
+
+pkgname = python2-powerline-git
+ depends = python2>=2.6
+ optdepends = python2-psutil: improved system information
+ optdepends = python2-pygit2: improved git support
+ optdepends = mercurial: improved mercurial support
+ optdepends = zsh: better shell prompt
+ optdepends = gvim: vim compiled with Python support
+ conflicts = python2-powerline
+ conflicts = python-powerline-git
+ conflicts = python-powerline
+ conflicts = otf-powerline-symbols-git
+
+pkgname = python-powerline-git
+ depends = python>=3.2
+ optdepends = python-psutil: improved system information
+ optdepends = python-pygit2: improved git support
+ optdepends = zsh: better shell prompt
+ optdepends = gvim: vim compiled with Python support
+ conflicts = python2-powerline
+ conflicts = python2-powerline-git
+ conflicts = python-powerline
+ conflicts = otf-powerline-symbols-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..764b1342fd67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Timothée Ravier <tim@siosm.fr>
+# Contributor: Pablo Olmos de Aguilera C. pablo+aur at odac dot co
+# Contributor: Kim Silkebækken <kim.silkebaekken+aur@gmail.com>
+
+_gitname=powerline
+_gitbranch=develop
+pkgbase=python-powerline-git
+pkgname=('python2-powerline-git' 'python-powerline-git')
+pkgdesc='The ultimate statusline/prompt utility'
+pkgver=2381.03195cf
+pkgrel=1
+url='https://github.com/powerline/powerline'
+license=('MIT')
+arch=('i686' 'x86_64')
+install="${_gitname}.install"
+source=("${_gitname}::git://github.com/powerline/${_gitname}.git#branch=${_gitbranch}"
+ "${install}")
+sha256sums=('SKIP'
+ 'af07852748ddba1544feee53fdf747d3dd163597f026719f8a6f80045d0c5425')
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git rev-list --count ${_gitbranch}).$(git rev-parse --short ${_gitbranch})"
+}
+
+package_generic() {
+ # Fonts
+ install -dm755 "${pkgdir}/etc/fonts/conf.d"
+ install -Dm644 "font/PowerlineSymbols.otf" "${pkgdir}/usr/share/fonts/OTF/PowerlineSymbols.otf"
+ install -Dm644 "font/10-powerline-symbols.conf" "${pkgdir}/etc/fonts/conf.avail/10-powerline-symbols.conf"
+ ln -s "../conf.avail/10-powerline-symbols.conf" "${pkgdir}/etc/fonts/conf.d/10-powerline-symbols.conf"
+
+ # Vim Plugin
+ install -Dm644 "powerline/bindings/vim/plugin/powerline.vim" "${pkgdir}/usr/share/vim/vimfiles/plugin/powerline.vim"
+
+ # Zsh Plugin
+ install -Dm644 "powerline/bindings/zsh/powerline.zsh" "${pkgdir}/usr/share/zsh/site-contrib/powerline.zsh"
+
+ # Tmux Configuration
+ install -Dm644 "powerline/bindings/tmux/powerline.conf" "${pkgdir}/usr/share/tmux/powerline.conf"
+
+ # License
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-powerline-git() {
+ depends=('python2>=2.6')
+ optdepends=('python2-psutil: improved system information'
+ 'python2-pygit2: improved git support'
+ 'mercurial: improved mercurial support'
+ 'zsh: better shell prompt'
+ 'gvim: vim compiled with Python support')
+ makedepends=('git' 'python2-setuptools')
+ conflicts=('python2-powerline'
+ 'python-powerline-git'
+ 'python-powerline'
+ 'otf-powerline-symbols-git')
+
+ cd "${_gitname}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ package_generic
+}
+
+package_python-powerline-git() {
+ depends=('python>=3.2')
+ optdepends=('python-psutil: improved system information'
+ 'python-pygit2: improved git support'
+ 'zsh: better shell prompt'
+ 'gvim: vim compiled with Python support')
+ makedepends=('git' 'python-setuptools')
+ conflicts=('python2-powerline'
+ 'python2-powerline-git'
+ 'python-powerline'
+ 'otf-powerline-symbols-git')
+
+ cd "${_gitname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ package_generic
+}
diff --git a/powerline.install b/powerline.install
new file mode 100644
index 000000000000..2a1aa34922e8
--- /dev/null
+++ b/powerline.install
@@ -0,0 +1,43 @@
+post_install() {
+ echo "Updating font cache..."
+ fc-cache -f
+
+ echo "
+IMPORTANT
+=========
+
+Powerline requires custom glyphs to work properly. A font with these glyphs has
+been installed along with a fontconfig file which enables the glyphs for many
+common coding fonts.
+
+If Powerline doesn't work out of the box on your system, please submit an issue
+on GitHub: https://github.com/powerline/powerline/issues
+
+Consult the documentation for detailed installation instructions and
+troubleshooting information: https://powerline.readthedocs.org/en/latest/
+
+Vim installation
+----------------
+
+The plugin has been installed and is enabled by default.
+
+Zsh installation
+----------------
+
+Add the following line to your ~/.zshrc:
+
+ . /usr/share/zsh/site-contrib/powerline.zsh
+
+Tmux installation
+-----------------
+
+Add the following line to your ~/.tmux.conf:
+
+ source '/usr/share/tmux/powerline.conf'
+"
+}
+
+post_remove() {
+ echo "Updating font cache..."
+ fc-cache -f
+}