summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Sandberg2019-05-02 10:14:26 +0200
committerJan Sandberg2019-05-02 10:39:06 +0200
commit2ac9ecbf0352bdeaaebecc1851cfbb3b632e739f (patch)
treec958f013f2e3bf7bc3a79a8158ffd2b967a1c32b
downloadaur-2ac9ecbf0352bdeaaebecc1851cfbb3b632e739f.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD36
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90cb615fb0e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-poxls-git
+ pkgdesc = Convert between Excel and PO files
+ pkgver = 1.4.2.r1.g24b7c5c
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/poxls
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-click
+ depends = python-openpyxl
+ depends = python-polib
+ provides = python-poxls
+ conflicts = python-poxls
+ source = poxls::git+https://github.com/wichert/po-xls.git
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = c909022c938835ff0a322a536315c193732bcd308bae4538fc81cc21896230e1
+
+pkgname = python-poxls-git
+ depends = python
+ depends = python-click
+ depends = python-openpyxl
+ depends = python-polib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7e682a397c5a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/poxls
+/*.pkg.tar.xz
+/src
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..771afc4e344f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 2017, wichert
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+3. All advertising materials mentioning features or use of this software must
+ display the following acknowledgement:
+ This product includes software developed by wichert.
+4. Neither the name of wichert nor the names of its contributors may be used to
+ endorse or promote products derived from this software without specific prior
+ written permission.
+
+THIS SOFTWARE IS PROVIDED BY wichert ''AS IS'' AND ANY EXPRESS OR IMPLIED
+WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
+SHALL wichert BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
+OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
+OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5ade3efd8ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jan Sandberg <jan dot sandberg at gmx dot ch>
+
+pkgname=python-poxls-git
+conflicts=('python-poxls')
+provides=('python-poxls')
+_pkgname=poxls
+pkgver=1.4.2.r1.g24b7c5c
+pkgrel=1
+pkgdesc='Convert between Excel and PO files'
+url='https://pypi.python.org/pypi/poxls'
+arch=('any')
+license=('BSD')
+_deps=('click' 'openpyxl' 'polib')
+makedepends=('git' 'python-setuptools')
+depends=("${_deps[@]/#/python-}")
+source=("poxls::git+https://github.com/wichert/po-xls.git"
+ "LICENSE")
+sha256sums=('SKIP'
+ 'c909022c938835ff0a322a536315c193732bcd308bae4538fc81cc21896230e1')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's:^release/::;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package_python-poxls-git() {
+ depends=('python' "${_deps[@]/#/python-}")
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}