summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-11-23 19:54:53 +0200
committerMartino Pilia2019-11-23 19:54:53 +0200
commit8c950ffb2a691c3fb97c305ddfe9d05cc778e515 (patch)
treedd0ab41696676a375dfd89775195603092990e68
parent6b1dcc6129b718cfa9b507dbaaa8df9ee25d7a83 (diff)
downloadaur-8c950ffb2a691c3fb97c305ddfe9d05cc778e515.tar.gz
Python 3.8
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e0d0fd18db4..ad81e6d80c18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pptk-git
pkgdesc = Python package for visualizing and processing 2-d/3-d point clouds
pkgver = r49.697c09a
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/heremaps/pptk.git
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 63764b87c68f..8839c49ed1cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=pptk
pkgname=python-$_name-git
pkgver=r49.697c09a
-pkgrel=1
+pkgrel=2
pkgdesc="Python package for visualizing and processing 2-d/3-d point clouds"
arch=('x86_64')
url="https://github.com/heremaps/pptk.git"
@@ -57,8 +57,9 @@ build() {
package() {
cd "$srcdir/$_name"
+ _py_version=$(python --version | grep -o '[0-9]\.[0-9]\+')
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ./dist/*.whl
- python -O -m compileall "${pkgdir}/usr/lib/python3.8/site-packages/$_name"
- ln -s /usr/lib/qt/plugins "${pkgdir}/usr/lib/python3.8/site-packages/$_name/libs/qt_plugins"
+ python -O -m compileall "${pkgdir}/usr/lib/python${_py_version}/site-packages/$_name"
+ ln -s /usr/lib/qt/plugins "${pkgdir}/usr/lib/python${_py_version}/site-packages/$_name/libs/qt_plugins"
}