summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-11-28 12:11:07 +0200
committerMartino Pilia2019-11-28 12:11:07 +0200
commitb59c46593ae6b01b704bb6c1c7af55e8c08042f9 (patch)
tree13eead3f5f4ab810d9d96dc406f5ce8b09f65bdb
parentd3bd8a9e6c800a3aa0485cb1309a35cf554ddaaa (diff)
downloadaur-b59c46593ae6b01b704bb6c1c7af55e8c08042f9.tar.gz
Fix qt plugin path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9c25807e24b..9dbf02f50923 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pptk-git
pkgdesc = Python package for visualizing and processing 2-d/3-d point clouds
pkgver = r49.697c09a
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/heremaps/pptk.git
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index a9bd80973d08..ad6b5923e99a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=pptk
pkgname=python-$_name-git
pkgver=r49.697c09a
-pkgrel=3
+pkgrel=4
pkgdesc="Python package for visualizing and processing 2-d/3-d point clouds"
arch=('x86_64')
url="https://github.com/heremaps/pptk.git"
@@ -38,6 +38,7 @@ prepare() {
cd "$srcdir/$_name"
sed -i 's,.*,,g' pptk/libs/CMakeLists.txt
sed -i 's,PythonLibs 2.7 REQUIRED,PythonLibs 3.5 REQUIRED,' CMakeLists.txt
+ sed -i 's,../libs/qt_plugins,/usr/lib/qt/plugins,' pptk/viewer/qt.conf
cmake . \
-DEigen_INCLUDE_DIR:FILEPATH="/usr/include/eigen3" \
-DNumpy_INCLUDE_DIR="$(python -c 'import numpy; print("%s/numpy" % numpy.get_include())')" \
@@ -60,6 +61,5 @@ package() {
_py_version=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ./dist/*.whl
python -O -m compileall "${pkgdir}/usr/lib/python${_py_version}/site-packages/$_name"
- ln -s /usr/lib/qt/plugins "${pkgdir}/usr/lib/python${_py_version}/site-packages/$_name/libs/qt_plugins"
}