summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-11-23 20:04:37 +0200
committerMartino Pilia2019-11-23 20:04:37 +0200
commitd3bd8a9e6c800a3aa0485cb1309a35cf554ddaaa (patch)
tree3a2078bfbe41a026e3cca10f8dbd242a71c45ef4
parent8c950ffb2a691c3fb97c305ddfe9d05cc778e515 (diff)
downloadaur-d3bd8a9e6c800a3aa0485cb1309a35cf554ddaaa.tar.gz
No hard-coded Python version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad81e6d80c18..e9c25807e24b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pptk-git
pkgdesc = Python package for visualizing and processing 2-d/3-d point clouds
pkgver = r49.697c09a
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/heremaps/pptk.git
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 8839c49ed1cd..a9bd80973d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=pptk
pkgname=python-$_name-git
pkgver=r49.697c09a
-pkgrel=2
+pkgrel=3
pkgdesc="Python package for visualizing and processing 2-d/3-d point clouds"
arch=('x86_64')
url="https://github.com/heremaps/pptk.git"
@@ -57,7 +57,7 @@ build() {
package() {
cd "$srcdir/$_name"
- _py_version=$(python --version | grep -o '[0-9]\.[0-9]\+')
+ _py_version=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ./dist/*.whl
python -O -m compileall "${pkgdir}/usr/lib/python${_py_version}/site-packages/$_name"
ln -s /usr/lib/qt/plugins "${pkgdir}/usr/lib/python${_py_version}/site-packages/$_name/libs/qt_plugins"