summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182022-04-04 18:19:20 +0200
committerLukas18182022-04-04 18:19:20 +0200
commitda5bbaa1bd738c8f1d7e7cae8a24cccad23d1e7a (patch)
tree7ed184c0059ed16279360e8a13dd0e0baac9dc00
downloadaur-python-praktikum.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9a194a051ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-praktikum
+ pkgdesc = Tools for the beginners' lab courses in physics at RWTH Aachen University
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = https://pgp.physik.rwth-aachen.de/software/
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = python-future
+ depends = python-uncertainties
+ source = https://files.pythonhosted.org/packages/source/p/praktikum/praktikum-2.4.0.tar.gz
+ sha512sums = 3c1f28df54dc6c40bff7d2c12c9d807d240f62a7e336390ad85b4c6941c92272ea0796947562634c25f4eac68f0689248bf9ffc6bda475679abeea2fcb64d428
+
+pkgname = python-praktikum
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..672cedb532fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lukas1818 aur at lukas1818 dot de
+
+pkgname=python-praktikum
+_name=${pkgname#python-}
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="Tools for the beginners' lab courses in physics at RWTH Aachen University"
+arch=('any')
+url="https://pgp.physik.rwth-aachen.de/software/"
+license=('MIT')
+depends=('python' 'python-numpy' 'python-scipy' 'python-matplotlib' 'python-future' 'python-uncertainties')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha512sums=('3c1f28df54dc6c40bff7d2c12c9d807d240f62a7e336390ad85b4c6941c92272ea0796947562634c25f4eac68f0689248bf9ffc6bda475679abeea2fcb64d428')
+
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}