summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Hamilton2016-02-24 05:17:58 -0500
committerMatt Hamilton2016-02-24 05:17:58 -0500
commitb867c29635261ca486811a168eaf2ff68b37d54e (patch)
tree4e02217cf35a5cae04829720db546b3992bea9cc
downloadaur-b867c29635261ca486811a168eaf2ff68b37d54e.tar.gz
prawoauth2 v0.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1441ca6b9288
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Feb 24 10:15:34 UTC 2016
+pkgbase = python-prawoauth2
+ pkgdesc = prawoauth2 is a helper library which makes writing Reddit bots/apps using OAuth2 super easy and simple.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/avinassh/prawoauth2
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-praw
+ makedepends = python-tornado
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/prawoauth2/prawoauth2-0.3.tar.gz
+ md5sums = d93d3a1ef16ac90e36f806123f38f0ff
+
+pkgname = python-prawoauth2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3027c4a7dcef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Author: Eriner <M@tthamilton.com>
+# Maintainer: Eriner <M@tthamilton.com>
+
+pkgname=python-prawoauth2
+pkgver=0.3
+pkgrel=1
+pkgdesc='prawoauth2 is a helper library which makes writing Reddit bots/apps using OAuth2 super easy and simple.'
+arch=(any)
+url='https://github.com/avinassh/prawoauth2'
+license=('MIT')
+makedepends=('python-setuptools' 'python-praw' 'python-tornado')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/p/prawoauth2/prawoauth2-${pkgver}.tar.gz")
+md5sums=('d93d3a1ef16ac90e36f806123f38f0ff')
+
+build() {
+ cd "prawoauth2-${pkgver}"
+ python3 setup.py build
+}
+
+package() {
+ cd "prawoauth2-${pkgver}"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}