summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2018-11-23 09:30:29 -0700
committerMark Wagie2018-11-23 09:30:29 -0700
commit0943aef0aaa820fc7eb117d0b5d7e676c8eaa00a (patch)
treed4ac2a7750e24471971e1f5aed3dad4f09a19a4d
parent8c1830fd7bd4878cd569b12ac1741c6fcbdcd57c (diff)
downloadaur-0943aef0aaa820fc7eb117d0b5d7e676c8eaa00a.tar.gz
optimized build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3311b534ab5..3f7ca28b721d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-privy-git
pkgdesc = An easy, fast lib to correctly password-protect your data
pkgver = r67.624bb58
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/ofek/privy
arch = any
license = dual
diff --git a/PKGBUILD b/PKGBUILD
index 8ea3926e8eee..8c5f55b0f4a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=python-privy-git
pkgver=r67.624bb58
-pkgrel=3
+pkgrel=4
pkgdesc="An easy, fast lib to correctly password-protect your data"
arch=('any')
url="https://github.com/ofek/privy"
@@ -21,9 +21,14 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/${pkgname}"
+ python setup.py build
+}
+
package() {
cd "$srcdir/${pkgname}"
- python setup.py install --root="$pkgdir/"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 "$srcdir/LICENSE-MIT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
install -Dm644 "$srcdir/LICENSE-APACHE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE-APACHE"
}