diff options
author | yochananmarqos | 2020-01-28 17:15:23 -0700 |
---|---|---|
committer | yochananmarqos | 2020-01-28 17:15:23 -0700 |
commit | eeff752827a9daeeb58e7590155be03b7540b5e0 (patch) | |
tree | 0ae1fe06b029a415248dbc53e3c5d3a9a231449e | |
parent | 51d58d3e028acade47f85bf57e99d7ac014e763c (diff) | |
download | aur-eeff752827a9daeeb58e7590155be03b7540b5e0.tar.gz |
PKGBUILD tweaks
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | PKGBUILD | 11 |
2 files changed, 9 insertions, 7 deletions
@@ -4,13 +4,14 @@ pkgbase = python-privy-git pkgrel = 5 url = https://github.com/ofek/privy arch = any - license = dual + license = MIT + license = Apache makedepends = python-setuptools depends = python-cryptography depends = python-argon2_cffi provides = python-privy conflicts = python-privy - source = python-privy::git+https://github.com/ofek/privy.git + source = git+https://github.com/ofek/privy.git sha256sums = SKIP pkgname = python-privy-git @@ -1,30 +1,31 @@ # Maintainer: Mark Wagie <mark dot wagie at tutanota dot com> pkgname=python-privy-git +_name=privy pkgver=r67.624bb58 pkgrel=5 pkgdesc="An easy, fast lib to correctly password-protect your data" arch=('any') url="https://github.com/ofek/privy" -license=('dual') +license=('MIT' 'Apache') depends=('python-cryptography' 'python-argon2_cffi') makedepends=('python-setuptools') provides=("${pkgname%-git}") conflicts=("${pkgname%-git}") -source=("${pkgname%-git}::git+https://github.com/ofek/privy.git") +source=('git+https://github.com/ofek/privy.git') sha256sums=('SKIP') pkgver() { - cd "$srcdir/${pkgname%-git}" + cd "$srcdir/$_name" printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" } build() { - cd "$srcdir/${pkgname%-git}" + cd "$srcdir/$_name" python setup.py build } package() { - cd "$srcdir/${pkgname%-git}" + cd "$srcdir/$_name" python setup.py install --root="$pkgdir/" --optimize=1 --skip-build install -Dm644 LICENSE-MIT LICENSE-APACHE -t "$pkgdir/usr/share/licenses/${pkgname%-git}" |