summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWeirch Sodora2015-08-14 16:48:31 +0800
committerWeirch Sodora2015-08-14 16:48:31 +0800
commit9470e50e515140799131b222edb4ada16d3d124b (patch)
tree694b72c7f168e2edd255daeeb581d1b10f6c227f
downloadaur-9470e50e515140799131b222edb4ada16d3d124b.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07733772439f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-proboscis
+ pkgdesc = Proboscis is a Python test framework that extends Python’s built-in unittest module and Nose with features from TestNG.
+ pkgver = 1.2.6.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/proboscis/
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = http://pypi.python.org/packages/source/p/proboscis/proboscis-1.2.6.0.tar.gz
+ md5sums = e4b36449ef7c18f70b8243f4c8bddbca
+
+pkgname = python-proboscis
+ depends = python
+
+pkgname = python2-proboscis
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..295e61979b15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Weirch Sodora <sodora at gmail dot com>
+
+pkgbase=python-proboscis
+pkgname=('python-proboscis' 'python2-proboscis')
+pkgver=1.2.6.0
+pkgrel=1
+pkgdesc='Proboscis is a Python test framework that extends Python’s built-in unittest module and Nose with features from TestNG.'
+arch=('any')
+url='https://pypi.python.org/pypi/proboscis/'
+license=('Apache')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("http://pypi.python.org/packages/source/p/proboscis/proboscis-${pkgver}.tar.gz")
+md5sums=('e4b36449ef7c18f70b8243f4c8bddbca')
+
+prepare() {
+ cd "${srcdir}"
+ cp -a proboscis-${pkgver} proboscis-${pkgver}-py2
+}
+
+package_python-proboscis() {
+ depends=('python')
+ cd "${srcdir}/proboscis-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+package_python2-proboscis() {
+ depends=('python2')
+ cd "${srcdir}/proboscis-${pkgver}-py2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}
+