summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2016-12-30 14:45:20 +1100
committerMatthew Gamble2016-12-30 14:45:20 +1100
commit7151d0e34401e08b9262a2c8db49226437583d6c (patch)
tree37d1e0b36452b260309383b7ea86c5ede7fe91ee
parente29f52fb5e4dac10020b20a75aac3c88e8ad98a6 (diff)
downloadaur-7151d0e34401e08b9262a2c8db49226437583d6c.tar.gz
Update to v0.10.1, add python-setuptools as a make dependency
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD5
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2683e50f837..874d97f3d9ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
# Generated by mksrcinfo v8
-# Wed Oct 5 11:46:16 UTC 2016
+# Fri Dec 30 03:44:35 UTC 2016
pkgbase = python-proc
pkgdesc = Simple interface to Linux process information
- pkgver = 0.9.1
+ pkgver = 0.10.1
pkgrel = 1
url = https://github.com/xolox/python-proc
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python
depends = python-coloredlogs
depends = python-executor
depends = python-humanfriendly
depends = python-property-manager
- source = https://github.com/xolox/python-proc/archive/0.9.1.tar.gz
- md5sums = 9c6452e3025fbd80ee0eec10cc5aafc7
+ source = https://github.com/xolox/python-proc/archive/0.10.1.tar.gz
+ sha512sums = b1c41ec143470994a7239b033123113be3eb9f95ee78f14d3fd92f7fbb9061bc35776b71e037e7ab7b538e989c7e10cb89f0ff1f6782a53c9724ecc4fa051a67
pkgname = python-proc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7294e1502285
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.xz
+/pkg/
+/srv/
diff --git a/PKGBUILD b/PKGBUILD
index 4f622fa06bc9..e73852209418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=python-proc
-pkgver=0.9.1
+pkgver=0.10.1
pkgrel=1
pkgdesc="Simple interface to Linux process information"
arch=("any")
url="https://github.com/xolox/python-proc"
license=("MIT")
depends=("python" "python-coloredlogs" "python-executor" "python-humanfriendly" "python-property-manager")
+makedepends=("python-setuptools")
source=("https://github.com/xolox/python-proc/archive/${pkgver}.tar.gz")
-md5sums=("9c6452e3025fbd80ee0eec10cc5aafc7")
+sha512sums=("b1c41ec143470994a7239b033123113be3eb9f95ee78f14d3fd92f7fbb9061bc35776b71e037e7ab7b538e989c7e10cb89f0ff1f6782a53c9724ecc4fa051a67")
package() {
cd "python-proc-${pkgver}"