summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-17 02:08:27 +0300
committerDimitris Kiziridis2020-07-17 02:08:27 +0300
commite9006774f8b48dbe812def8e18d8169d88d27f19 (patch)
treef83480d7f97ccc1af793f910d7f64629454db4d4
downloadaur-e9006774f8b48dbe812def8e18d8169d88d27f19.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7aaedb5031b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-prompt_toolkit1014
+ pkgdesc = A library for building powerful interactive command lines and terminal applications in Python
+ pkgver = 1.0.14
+ pkgrel = 1
+ url = https://github.com/jonathanslenders/python-prompt-toolkit
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-six
+ depends = python-wcwidth
+ provides = python-prompt_toolkit=1.0.14
+ source = python-prompt_toolkit1014-1.0.14.tar.gz::https://files.pythonhosted.org/packages/55/56/8c39509b614bda53e638b7500f12577d663ac1b868aef53426fc6a26c3f5/prompt_toolkit-1.0.14.tar.gz
+ sha256sums = cc66413b1b4b17021675d9f2d15d57e640b06ddfd99bb724c73484126d22622f
+
+pkgname = python-prompt_toolkit1014
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83a6b3b019fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=python-prompt_toolkit1014
+pkgver=1.0.14
+pkgrel=1
+pkgdesc='A library for building powerful interactive command lines and terminal applications in Python'
+arch=('any')
+url="https://github.com/jonathanslenders/python-prompt-toolkit"
+license=('BSD')
+provides=('python-prompt_toolkit=1.0.14')
+depends=('python-six'
+ 'python-wcwidth')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/55/56/8c39509b614bda53e638b7500f12577d663ac1b868aef53426fc6a26c3f5/prompt_toolkit-${pkgver}.tar.gz")
+sha256sums=('cc66413b1b4b17021675d9f2d15d57e640b06ddfd99bb724c73484126d22622f')
+
+package() {
+ cd "prompt_toolkit-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file