summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrkcf2019-05-15 11:47:16 -0700
committerrkcf2019-05-15 11:47:16 -0700
commita39e12806879da85332f4c6a7e52a28c8519d066 (patch)
tree62beb4c8abe6d6e53b9e1bba037df90f555d1b4c
parentfed572c16cf38485a1d9688778f6b9ac1b199c78 (diff)
downloadaur-a39e12806879da85332f4c6a7e52a28c8519d066.tar.gz
update to v1.1.5
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD47
2 files changed, 40 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e252f14f0b8..b186f8056d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
pkgbase = python-prospector
pkgdesc = Python static analysis tool
- pkgver = 1.1.1
+ pkgver = 1.1.5
pkgrel = 1
url = https://github.com/PyCQA/prospector
arch = any
license = GPL2
- depends = python-setuptools
- depends = python-pydocstyle
- depends = python-pep8-naming
- depends = python-mccabe
- depends = python-pycodestyle
- depends = python-pyflakes
- depends = python-yaml
- depends = python-dodgy
- depends = python-setoptconf
+ makedepends = python-setuptools
+ depends = python-pylint-celery
+ depends = python-pylint-flask
+ depends = python-pylint-django
depends = python-requirements-detector
- depends = python-pylint-common
- depends = python-pylint-plugin-utils
- source = https://github.com/PyCQA/prospector/archive/1.1.1.tar.gz
- md5sums = a4a73a42bf50a21f84bc94e3d42ca81d
+ depends = python-setoptconf
+ depends = python-dodgy
+ depends = python-pyaml
+ depends = python-pycodestyle
+ depends = python-pep8-naming
+ depends = python-pydocstyle
+ optdepends = python-pyroma: check setup.py
+ optdepends = python-vulture: find dead code
+ optdepends = python-mypy: optional type checking
+ source = https://github.com/PyCQA/prospector/archive/1.1.5.tar.gz
+ md5sums = 222892e4f96752ea34a89b9152e35136
pkgname = python-prospector
diff --git a/PKGBUILD b/PKGBUILD
index 04abbf51aad..a109d1256f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,39 @@
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=python-prospector
-pkgver=1.1.1
+_pkgname=prospector
+pkgver=1.1.5
pkgrel=1
pkgdesc="Python static analysis tool"
arch=('any')
-depends=('python-setuptools'
- 'python-pydocstyle'
- 'python-pep8-naming'
- 'python-mccabe'
- 'python-pycodestyle'
- 'python-pyflakes'
- 'python-yaml'
- 'python-dodgy'
- 'python-setoptconf'
- 'python-requirements-detector'
- 'python-pylint-common'
- 'python-pylint-plugin-utils')
-optdeps=('python-pyroma: check setup.py'
- 'python-vulture: find dead code'
- 'python-mypy: optional type checking')
+depends=('python-pylint-celery'
+ 'python-pylint-flask'
+ 'python-pylint-django'
+ 'python-requirements-detector'
+ 'python-setoptconf'
+ 'python-dodgy'
+ 'python-pyaml'
+ 'python-pycodestyle'
+ 'python-pep8-naming'
+ 'python-pydocstyle')
+makedepends=('python-setuptools')
+optdepends=('python-pyroma: check setup.py'
+ 'python-vulture: find dead code'
+ 'python-mypy: optional type checking')
url="https://github.com/PyCQA/prospector"
license=('GPL2')
-source=(${url}/archive/${pkgver}.tar.gz)
-md5sums=('a4a73a42bf50a21f84bc94e3d42ca81d')
+source=("$url/archive/$pkgver.tar.gz")
+md5sums=('222892e4f96752ea34a89b9152e35136')
build() {
- cd "$srcdir/${pkgname#python-}-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/${pkgname#python-}-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
+
# vim:set ts=2 sw=2 et: