summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenri Chain2017-05-27 02:54:42 +0200
committerHenri Chain2017-05-27 02:54:42 +0200
commitce2cc7e2ab38617d4bbc5c5c2faf181ac9c2ebf8 (patch)
tree6ca470d361d69251f3a04b41fc438ee1bef4f548
downloadaur-ce2cc7e2ab38617d4bbc5c5c2faf181ac9c2ebf8.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f41644532aeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat May 27 00:54:09 UTC 2017
+pkgbase = python-protobuf-to-dict
+ pkgdesc = A teeny Python library for creating Python dicts from protocol buffers and the reverse. Useful as an intermediate step before serialisation (e.g. to JSON).
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/benhodgson/protobuf-to-dict
+ arch = any
+ license = CUSTOM
+ makedepends = python-distribute
+ depends = python
+ source = https://github.com/kaporzhu/protobuf-to-dict/archive/v0.1.5.zip
+ md5sums = 8e18e6fbdc1e4139f3905ff92919e99f
+
+pkgname = python-protobuf-to-dict
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63c74980d035
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Henri Chain <henri@henri-chain.com>
+_pkgname=protobuf-to-dict
+pkgname=python-${_pkgname}
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="A teeny Python library for creating Python dicts from protocol buffers and the reverse. Useful as an intermediate step before serialisation (e.g. to JSON)."
+url="https://github.com/benhodgson/protobuf-to-dict"
+depends=('python' )
+makedepends=('python-distribute' )
+license=('CUSTOM')
+arch=('any')
+source=("https://github.com/kaporzhu/${_pkgname}/archive/v${pkgver}.zip")
+md5sums=('8e18e6fbdc1e4139f3905ff92919e99f')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}