summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2024-04-28 16:24:28 +0330
committerAli Molaei2024-04-28 16:24:28 +0330
commitc6d41d8fe1ca74ebef13c729efeafd55aaac2864 (patch)
tree0061b9a25b68a67e1b27ea32b29d0bcb4a38eeec
parent3aa3472e1f5fbb6494b8085d55efeb50ea52ef08 (diff)
downloadaur-c6d41d8fe1ca74ebef13c729efeafd55aaac2864.tar.gz
Add git to make-deps, add checksum
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19ed384844f6..89062a564497 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-proton-core
pkgdesc = The proton-core component contains core logic used by the other Proton components.
pkgver = 0.1.16
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ProtonVPN/python-proton-core
arch = any
groups = ProtonVPN
license = GPL3
+ makedepends = git
makedepends = python-setuptools
source = git+https://github.com/ProtonVPN/python-proton-core.git#tag=v0.1.16
- sha256sums = SKIP
+ sha256sums = 266d69691dafb6d2d6010c959850372467dc56410960757881e864362e064240
pkgname = python-proton-core
diff --git a/PKGBUILD b/PKGBUILD
index 37de395f4016..bc75a35acb19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
pkgname=python-proton-core
-_gitpkgname=python-proton-core
pkgver=0.1.16
-pkgrel=2
+pkgrel=3
pkgdesc="The proton-core component contains core logic used by the other Proton components."
arch=("any")
url="https://github.com/ProtonVPN/python-proton-core"
license=("GPL3")
groups=("ProtonVPN")
-makedepends=("python-setuptools")
-source=("git+https://github.com/ProtonVPN/${_gitpkgname}.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+makedepends=("git" "python-setuptools")
+source=("git+https://github.com/ProtonVPN/${pkgname}.git#tag=v${pkgver}")
+sha256sums=('266d69691dafb6d2d6010c959850372467dc56410960757881e864362e064240')
build() {
- cd "$_gitpkgname"
+ cd "$pkgname"
python setup.py build
}
package() {
- cd "$_gitpkgname"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
}