summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2021-08-18 23:31:23 +0200
committerMarius Lindvall2021-08-18 23:31:23 +0200
commit5d4336db21f86c8de8b2ea4d57e1abeafb9f282a (patch)
tree51377d0d0265201f4d84a89a60e2e2e9df6bcf39
downloadaur-5d4336db21f86c8de8b2ea4d57e1abeafb9f282a.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a39165f907b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-proxy_tools
+ pkgdesc = Simple proxy implementation for Python
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/jtushman/proxy_tools
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/source/p/proxy_tools/proxy_tools-0.1.0.tar.gz
+ source = https://raw.githubusercontent.com/jtushman/proxy_tools/master/LICENSE.txt
+ sha256sums = ccb3751f529c047e2d8a58440d86b205303cf0fe8146f784d1cbcd94f0a28010
+ sha256sums = a428fb8a2e762af3eb0a6edbbb88e9b42ccfee80fd9b423958bcacf9b9abbfe4
+
+pkgname = python-proxy_tools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75b3d7e2917b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
+
+pkgname=python-proxy_tools
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Simple proxy implementation for Python"
+arch=('any')
+url='https://github.com/jtushman/proxy_tools'
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://pypi.python.org/packages/source/p/proxy_tools/proxy_tools-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/jtushman/proxy_tools/master/LICENSE.txt")
+sha256sums=('ccb3751f529c047e2d8a58440d86b205303cf0fe8146f784d1cbcd94f0a28010'
+ 'a428fb8a2e762af3eb0a6edbbb88e9b42ccfee80fd9b423958bcacf9b9abbfe4')
+
+build() {
+ cd "${srcdir}/proxy_tools-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm 644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "proxy_tools-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}