summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-22 01:54:26 -0500
committerLuis Martinez2021-09-22 01:54:26 -0500
commit3f62b3ad10d19209758a91ea551618a15ace60ef (patch)
treefaf5f36bf691ae47334604eb64006648e55803ab
parent4ce60bc5d6eee8e6e5ab462ce65d9c13c8dc6ded (diff)
downloadaur-3f62b3ad10d19209758a91ea551618a15ace60ef.tar.gz
update to 0.7.6
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--releasenotes.rst65
4 files changed, 86 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b26bad5ffe06..1ede0f309bc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-pscript
pkgdesc = Python to JavaScript compiler
- pkgver = 0.7.4
- pkgrel = 2
+ pkgver = 0.7.6
+ pkgrel = 1
url = https://github.com/flexxui/pscript
arch = any
license = BSD
makedepends = python-setuptools
+ makedepends = python-sphinx
depends = python
- source = https://files.pythonhosted.org/packages/source/p/pscript/pscript-0.7.4.tar.gz
- sha256sums = 4cca30461bdcbefcb205a24dfb16ea764f43fc9d7ed06956dc01180cea9fe7ac
+ source = python-pscript-0.7.6.tar.gz::https://github.com/flexxui/pscript/archive/v0.7.6.tar.gz
+ sha256sums = 1bc8b5c1319e677837df5659289f14052c84da977c445acde95bf1ada653a6c5
pkgname = python-pscript
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 05c6d4d4c97b..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.gitignore
-!.SRCINFO
-!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 1c5407ef5976..f48299e07458 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Ronuk Raval <ronuk.raval at gmail dot com>
-_pkgname='pscript'
-pkgname="python-${_pkgname}"
-pkgver=0.7.4
-pkgrel=2
+pkgname=python-pscript
+pkgver=0.7.6
+pkgrel=1
pkgdesc='Python to JavaScript compiler'
arch=('any')
url='https://github.com/flexxui/pscript'
-_url_pypi='https://pypi.org/project/pscript'
license=('BSD')
depends=('python')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('4cca30461bdcbefcb205a24dfb16ea764f43fc9d7ed06956dc01180cea9fe7ac')
+makedepends=('python-setuptools' 'python-sphinx')
+changelog=releasenotes.rst
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('1bc8b5c1319e677837df5659289f14052c84da977c445acde95bf1ada653a6c5')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "pscript-$pkgver"
python setup.py build
+ cd docs
+ make man
}
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "pscript-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm 644 docs/_build/man/PScript.1 "$pkgdir/usr/share/man/man1/pscript.1"
}
# vim: ts=2 sw=2 et:
diff --git a/releasenotes.rst b/releasenotes.rst
new file mode 100644
index 000000000000..c98c3c26e285
--- /dev/null
+++ b/releasenotes.rst
@@ -0,0 +1,65 @@
+-------------
+Release notes
+-------------
+
+
+**v0.7.5** (04-01-2021)
+
+* Support for Python 3.9.
+* Small docs improvements.
+
+
+**v0.7.4** (11-05-2020)
+
+* Allow to rename functions starting with an uppercase letter.
+
+
+**v0.7.3** (16-12-2019)
+
+* Fix CI and Python 3.8 support.
+
+
+**v0.7.2** (16-12-2019)
+
+* Reflect AST changes in Python 3.8.
+
+
+**v0.7.1** (29-03-2019)
+
+* Fix the overloaded equals operation to be faster in common cases.
+
+
+**v0.7.0** (08-11-2018)
+
+* Add ability to reduce overloading of add, mul, equals and truthy.
+ https://pscript.readthedocs.io/en/latest/intro.html#pscript-overload
+
+
+**v0.6.0** (10-08-2018)
+
+* Support for ``async`` and ``await``.
+* Fixes for Python 3.7.
+* Improvements to formatting.
+
+
+**v0.5.5** (12-04-2018)
+
+* Support for Python 3.7.
+
+
+**v0.5.5** (11-04-2018)
+
+* Improved string formatting (e.g. ``'%+3.2f' % 3.1234``).
+* String formatting via ``str.format(...)`` and f-strings!
+* Dict literals are no longer limited to identifier-valid strings.
+* Fixed a few glitches and small bugs.
+
+
+**v0.5.3** (03-04-2018)
+
+PScript got its own github repo and was renamed from ``flexx.pyscript`` to ``pscript``.
+
+
+**Before March 2018**
+
+See the Flexx release notes.